easyVoice before 0.0.23 SSRF via openaiBaseUrl in TTS API
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- Proof of concept public, per CISA
- Fix
- Fixed in 0.0.23
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 0.0.23.
- Exploitation15/40CISA rates a proof of concept as public
- Exposure20/25No login or user action needed per the CVSS vector, CISA rates it automatable · Data gap: No advisory context yet
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity6.9/10CVSS 6.9
- No patch0/5No signal
What would change the score
- Would score about 72 if added to CISA KEV
- Would score about 67 if CISA's SSVC rates exploitation active
- Would score about 47 if advisories confirm default setups are exposed
CVE-2026-121936 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.9 (medium) and affects easyVoice; fixed in 0.0.23.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 42/100 · provisional
- Fix
- Fixed in 0.0.23
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: poc
- Automatable: yes
- Technical impact: partial
Summary
easyVoice versions before 0.0.23 can be abused remotely, without logging in, to make the server send POST requests to loopback and internal services by supplying a crafted openaiBaseUrl value to the TTS API when useLLM is enabled. Attackers can use the reflected error messages in the x-generate-tts-warning header to probe internal hosts and ports.
Read the original description
easyVoice before 0.0.23 contains a server-side request forgery vulnerability that allows unauthenticated attackers to make the server send POST requests by supplying openaiBaseUrl with useLLM enabled. Attackers can target loopback and internal services through /api/v1/tts endpoints, using reflected error messages in the x-generate-tts-warning header to probe internal hosts and ports.
What to do
Upgrade to a fixed version: 0.0.23.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: poc · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- cosin2077 easyVoice
fixed in 0.0.23
Evidence 6
- Patch
- Patch
- Report
- Repository
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121936
Is CVE-2026-121936 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-121936?
easyVoice: before 0.0.23.Source: cve.now feed data
How do I fix CVE-2026-121936?
Upgrade to a fixed version: 0.0.23.Source: cve.now feed data