Buffer overflow in SAML authentication post-back URL handling in libsnowflakeclient and Snowflake PHP PDO Driver
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 4.3.0, 2.11.1
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 4.3.0, 2.11.1.
- Exploitation0/40No signal
- Exposure3/25Reachable over the network · Data gap: No advisory context yet
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity7.6/10CVSS 6.6, total technical impact per CISA
- No patch0/5No signal
What would change the score
- Would score about 66 if added to CISA KEV
- Would score about 61 if CISA's SSVC rates exploitation active
- Would score about 30 if advisories confirm default setups are exposed
CVE-2026-121925 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.6 (medium) and affects Snowflake PHP PDO Driver and Snowflake Libsnowflakeclient; fixed in 4.3.0 and 2.11.1.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 11/100 · provisional
- Fix
- Fixed in 4.3.0, 2.11.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
The libsnowflakeclient library and Snowflake PHP PDO Driver have a stack-based buffer overflow in SAML single sign-on login handling that can be reached over the network by an attacker with high privileges, without any user action. An attacker who exploits it could crash the application or, in specific circumstances, execute remote code within the application's process.
Read the original description
A stack-based buffer overflow in libsnowflakeclient and the Snowflake PHP PDO Driver could, under specific conditions, result in memory corruption during SAML-based authentication. During a native SSO/SAML login flow, the affected drivers may have copied a value taken from the identity provider's HTML response into a fixed-size memory buffer without first validating the length of that value. An attacker who controlled or had compromised the configured identity provider — or who was able to redirect the SAML single sign-on endpoint to an attacker-controlled server — might have leveraged this by returning an oversized response, potentially resulting in a crash or, in specific circumstances, remote code execution within the context of the application running the library. The fix is available in libsnowflakeclient version 2.11.1 and Snowflake PHP PDO Driver version 4.3.0. Users must manually upgrade.
What to do
Upgrade to a fixed version: 4.3.0, 2.11.1.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Snowflake Snowflake PHP PDO Driver
From 3.2.0 · fixed in 4.3.0
- Snowflake Snowflake Libsnowflakeclient
From 2.1.0 · fixed in 2.11.1
Evidence 2
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121925
Is CVE-2026-121925 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-121925?
Snowflake PHP PDO Driver: from 3.2.0 before 4.3.0. Snowflake Libsnowflakeclient: from 2.1.0 before 2.11.1.Source: cve.now feed data
How do I fix CVE-2026-121925?
Upgrade to a fixed version: 4.3.0, 2.11.1.Source: cve.now feed data