@better-auth/expo before 1.7.16 allows certain account-takeover outcomes (e.g., unauthenticated changes of any account's email address)…
Affects Better Auth servers that register the expo() plugin from @better-auth/expo 1.4.0-beta.6 or later. Fixed in 1.7.16, or 1.8.0-beta.5 on the beta line.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 1.7.16
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Server registers the expo() plugin from @better-auth/expo 1.4.0-beta.6 or later
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure12/25Specific setups only, reachable over the network without a login
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity9.1/10CVSS 9.1
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
CVE-2026-121802 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.1 (critical) and affects Better Auth; fixed in 1.7.16.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.20% · 10th percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 21/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 1.7.16
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
@better-auth/expo, an authentication library for Expo apps, has a flaw that lets an attacker remotely, without logging in, take over accounts, such as by changing any account's email address. The fix requires rotating the application secret after updating.
Read the original description
@better-auth/expo before 1.7.16 allows certain account-takeover outcomes (e.g., unauthenticated changes of any account's email address), because it signs a caller-supplied state value without checking whether that value had been issued by the server. NOTE: the application secret must be rotated after updating to a fixed version.
What to do
Check whether your setup matches what the bug needs.
Server registers the expo() plugin from @better-auth/expo 1.4.0-beta.6 or laterUpgrade to a fixed version: 1.7.16.
Workaround: Remove the expo() server plugin if you do not use Expo social sign-in.
Timeline
- CVE published
- First seen by cve.now
- Record last updated
- Posted on X by cve.now
Affected versions
- better-auth Better Auth
fixed in 1.7.16
Evidence 3
- Advisory
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121802
Is CVE-2026-121802 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
An unauthenticated attacker who knows a user's email address can sign in as that user and change the account's email address. No action from the user is needed.Source: github.com
Which versions are affected by CVE-2026-121802?
Better Auth: before 1.7.16.Source: cve.now feed data
Am I affected, and how do I check?
Servers that register the expo() plugin from @better-auth/expo 1.4.0-beta.6 or later are affected. To check a project, look for expo() in the server's auth plugin setup and compare the installed @better-auth/expo version.Source: github.com
How do I fix CVE-2026-121802?
Upgrade both @better-auth/expo and better-auth to 1.7.16, or to 1.8.0-beta.5 on the beta line. If Expo social sign-in is not used, removing the expo() server plugin is also a listed workaround.Source: github.com