Kore before 4.3.0 Integer Underflow Memory Exhaustion via http_header_recv()
Affects Kore versions before 4.3.0. The fix is in Kore 4.3.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 4.3.0
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 4.3.0.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Data gap: Advisories don't say whether default setups are affected
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
CVE-2026-121727 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects kore; fixed in 4.3.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 4.3.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Kore, a C web application framework, is affected before version 4.3.0. An unauthenticated remote attacker can exploit an integer underflow in its HTTP request body handling to bypass the configured body size limit and exhaust server memory, potentially crashing or disrupting the service.
Read the original description
Kore before 4.3.0 contains an integer underflow vulnerability in HTTP request body handling that allows unauthenticated attackers to bypass http_body_max by sending more body bytes than declared. Attackers can send oversized first segments over many concurrent POST, PUT or DELETE connections, wrapping content_length to grow buffers unbounded and exhaust worker memory.
What to do
Upgrade to a fixed version: 4.3.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- jorisvink kore
fixed in 4.3.0
Evidence 5
- Patch
- Repository
- Repository
- Link
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121727
Is CVE-2026-121727 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
An integer underflow in Kore's http_header_recv() can cause the server to read data from the network into its http_body buffer until a 60 second timeout occurs. This can exhaust memory and cause a denial of service. The underflow is possible only in certain unspecified scenarios.Source: github.com
Which versions are affected by CVE-2026-121727?
kore: before 4.3.0.Source: cve.now feed data
Am I affected, and how do I check?
Kore versions before 4.3.0 are in the affected range. The sources do not specify which configurations or scenarios trigger the underflow, so the installed Kore version is the only check listed here.Source: github.com
How do I fix CVE-2026-121727?
Upgrade Kore to version 4.3.0 or later.Source: github.com