WatchGuard AuthPoint Gateway Improper Certificate Validation Allows Man-in-the-Middle Attacks
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 7.6.0
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 7.6.0.
- Exploitation0/40No signal
- Exposure17/25No login or user action needed, reachable over the network without a login · Data gap: Advisories don't say whether default setups are affected
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity10/10CVSS 9.1, total technical impact per CISA
- No patch0/5No signal
What would change the score
- Would score about 72 if added to CISA KEV
- Would score about 67 if CISA's SSVC rates exploitation active
- Would score about 32 if advisories confirm default setups are exposed
CVE-2026-121638 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.1 (critical) and affects AuthPoint Authentication Gateway; fixed in 7.6.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 27/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 7.6.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
WatchGuard AuthPoint Gateway has an improper certificate validation flaw that lets an attacker who is on the network path between the gateway and its local authentication providers intercept and modify their communications. The attack can be carried out remotely, without logging in, and does not require any action from a user.
Read the original description
An Improper Certificate Validation vulnerability in WatchGuard AuthPoint Gateway allows an attacker with an on-path network position to intercept and modify communications between the AuthPoint Gateway and local authentication providers.
What to do
Upgrade to a fixed version: 7.6.0.
Timeline
- CVE published
- First seen by cve.now
- Posted on X by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- WatchGuard AuthPoint Authentication Gateway
From 1.0 · fixed in 7.6.0
Evidence 1
- Advisory
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121638
Is CVE-2026-121638 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The gateway does not properly check the certificate of the servers it connects to. An attacker sitting on the network path between the AuthPoint Gateway and its local authentication providers can intercept and change the traffic between them.Source: psirt.watchguard.com
Which versions are affected by CVE-2026-121638?
AuthPoint Authentication Gateway: from 1.0 before 7.6.0.Source: cve.now feed data
Am I affected, and how do I check?
AuthPoint Authentication Gateway versions from 1.0 up to, but not including, 7.6.0 are affected. Only deployments configured with a RADIUS, LDAP or ADFS resource are in scope, so check the gateway version and whether any of those resource types are set up.Source: psirt.watchguard.com
How do I fix CVE-2026-121638?
Upgrade AuthPoint Authentication Gateway to version 7.6.0 or later, which contains the fix.Source: psirt.watchguard.com