Nanosystems Supremo before 5.0.2.3874 Improper TLS Certificate Validation
Supremo versions before 5.0.2.3874 on Windows or macOS fail to validate TLS certificates, which lets a man-in-the-middle read login data and alter traffic. Fixed in 5.0.2.3874.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 5.0.2.3874
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 5.0.2.3874.
- Exploitation0/40No signal
- Exposure?/25Exposure: unknown (data gap). Advisories don't say whether default setups are affected
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.6/10CVSS 7.6, total technical impact per CISA
- No patch0/5No signal
What would change the score
- Would score about 64 if added to CISA KEV
- Would score about 59 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
CVE-2026-121624 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.6 (high) and affects Supremo; fixed in 5.0.2.3874.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 9/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 5.0.2.3874
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Nanosystems Supremo for Windows and macOS, a remote-access application, fails to properly validate TLS certificates. An attacker on the same network can impersonate the server with a self-signed certificate, intercepting and reading usernames, password hashes, and license codes.
Read the original description
Nanosystems Supremo for Windows and macOS before 5.0.2.3874 contains an improper certificate validation vulnerability that allows adjacent attackers to intercept TLS connections by presenting untrusted certificates. Attackers on the same network can terminate and relay the client's TLS session using self-signed certificates to read usernames, SHA-256 password hashes, and license codes.
What to do
Upgrade to a fixed version: 5.0.2.3874.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Nanosystems Supremo
fixed in 5.0.2.3874
Evidence 4
- Link
- Link
- Link
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121624
Is CVE-2026-121624 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Supremo does not properly check the server's TLS certificate. An attacker in a man-in-the-middle position can intercept the session, read the username, SHA-256 password hash and software license code, and modify data exchanged between client and server.Source: pusi77.eu.org
Which versions are affected by CVE-2026-121624?
Supremo: before 5.0.2.3874.Source: cve.now feed data
Am I affected, and how do I check?
The affected versions are Supremo releases before 5.0, which are earlier than the fixed range listed as 5.0.2.3874. The product is available for Windows and macOS. To check, compare the installed Supremo version against 5.0.2.3874.Source: pusi77.eu.org
How do I fix CVE-2026-121624?
Upgrade Supremo to version 5.0.2.3874 or later, the release that fixes this issue.Source: pusi77.eu.org