Skip to main content
← Vulnerabilities

wlroots before 0.20.2 Out-of-Bounds Read via read_surface_class() in xwm.c

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

4.8MediumCNA
Exploited
No known exploitation
Fix
Fixed in 0.20.2
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 0.20.2.

5Pcve.now Index 5 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure?/25Exposure: unknown (data gap). No advisory context yet
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity4.8/10CVSS 4.8
  • No patch0/5No signal

What would change the score

  • Would score about 60 if added to CISA KEV
  • Would score about 55 if CISA's SSVC rates exploitation active
  • Would score about 27 if advisories confirm default setups are exposed

CVE-2026-121604 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 4.8 (medium) and affects wlroots; fixed in 0.20.2.

Published
Last modified
Published
Not listed in CISA KEV
5/100 · provisional
Fix
Fixed in 0.20.2
None on Exploit-DB, Metasploit or GitHub

Summary

wlroots, a library used to build Wayland compositors, is affected by an out-of-bounds read in its Xwayland window manager code. A local X11 client can exploit this to leak memory from the compositor's heap, which may then be exposed as a window class or app ID.

Read the original description

wlroots before 0.20.2 contains an out-of-bounds read vulnerability in read_surface_class() in xwayland/xwm.c that allows local X11 clients to leak compositor heap memory. Attackers can set a WM_CLASS property with a NUL-terminated instance but unterminated class, exposing over-read heap bytes as the window class or app_id over IPC.

What to do

  • Upgrade to a fixed version: 0.20.2.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • wlroots wlroots

    fixed in 0.20.2

Evidence 7

  1. Patch
  2. Patch
  3. Report
  4. Report
  5. Link
Show all 7 sourcesShow fewer sources
  1. Link
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-121604

Is CVE-2026-121604 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-121604?

wlroots: before 0.20.2.Source: cve.now feed data

How do I fix CVE-2026-121604?

Upgrade to a fixed version: 0.20.2.Source: cve.now feed data