TeXlyre from 0.11.0 before 0.13.5 Stored XSS via Recipe Icon Import
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 0.13.5
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 0.13.5.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure7/25Reachable over the network without a login · Data gap: No advisory context yet
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity5.3/10CVSS 5.3
- No patch0/5No signal
What would change the score
- Would score about 67 if added to CISA KEV
- Would score about 62 if CISA's SSVC rates exploitation active
- Would score about 27 if advisories confirm default setups are exposed
CVE-2026-121588 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.3 (medium) and affects texlyre; fixed in 0.13.5.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 12/100 · provisional
- Fix
- Fixed in 0.13.5
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
TeXlyre, a browser-based LaTeX editor, is affected by this vulnerability. An attacker who tricks a user into importing a malicious LSP or typesetter recipe can run arbitrary scripts that persist in the application, potentially gaining access to local projects and stored repository credentials.
Read the original description
TeXlyre from 0.11.0 before 0.13.5 contains a stored cross-site scripting vulnerability that allows attackers to execute script by supplying malicious LSP or typesetter recipe icons. Attackers can trick victims into importing a recipe whose icon contains an HTML event handler, persistently accessing local projects and repository credentials.
What to do
Upgrade to a fixed version: 0.13.5.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- TeXlyre texlyre
From 0.11.0 · fixed in 0.13.5
Evidence 4
- Advisory
- Patch
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121588
Is CVE-2026-121588 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-121588?
texlyre: from 0.11.0 before 0.13.5.Source: cve.now feed data
How do I fix CVE-2026-121588?
Upgrade to a fixed version: 0.13.5.Source: cve.now feed data