Out-of-bounds Write in µD3TN
Affects µD3TN versions before 0.15.2 when a bundle addressed to the local node carries the administrative record processing flag and arrives over mtcp, smtcp or TCPCLv3. Fixed in 0.15.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 0.15.2
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 0.15.2.
- Exploitation0/40No signal
- Exposure20/25No login or user action needed, CISA rates it automatable · Data gap: Advisories don't say whether default setups are affected
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity7.5/10CVSS 7.5
- No patch0/5No signal
What would change the score
- Would score about 73 if added to CISA KEV
- Would score about 68 if CISA's SSVC rates exploitation active
- Would score about 33 if advisories confirm default setups are exposed
CVE-2026-121510 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.5 (high) and affects µD3TN; fixed in 0.15.2.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 28/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 0.15.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
µD3TN, a software implementation of the Bundle Protocol used in delay-tolerant networking, is affected. A remote attacker who does not need to log in can send crafted data to its BPv6 administrative record parser, corrupting memory and reliably crashing the software, causing a denial of service.
Read the original description
Remote Unauthenticated Heap Out-of-Bounds Write in µD3TN BPv6 Administrative Record Parser allows Unauthenticated Remote Attacker to Reliably Cause DoS
What to do
Upgrade to a fixed version: 0.15.2.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- D3TN GmbH µD3TN
fixed in 0.15.2
Evidence 1
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121510
Is CVE-2026-121510 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A single bundle can write up to 65535 bytes of chosen content past a one-byte heap allocation. This corrupts the heap and terminates the node, causing loss of availability. Code execution cannot be excluded.Source: gitlab.com
Which versions are affected by CVE-2026-121510?
µD3TN: before 0.15.2.Source: cve.now feed data
Am I affected, and how do I check?
Versions from the start of the range up to but not including 0.15.2 are in scope. The bug needs a bundle whose destination is the node's own EID and that carries the administrative record processing flag, received over a listening mtcp, smtcp or TCPCLv3 convergence layer. Check the installed version and the node's configured convergence layers to see whether these conditions can apply.Source: gitlab.com
How do I fix CVE-2026-121510?
Upgrade µD3TN to 0.15.2 or later, which contains the fix.Source: gitlab.com