Skip to main content
← Vulnerabilities

Out-of-bounds Write in NTPsec

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.4HighCNA
Exploited
No known exploitation
Fix
Fixed in 1.2.5
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 1.2.5.

24Pcve.now Index 24 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure17/25No login or user action needed per the CVSS vector, reachable over the network without a login · Data gap: No advisory context yet
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity7.4/10CVSS 7.4
  • No patch0/5No signal

What would change the score

  • Would score about 69 if added to CISA KEV
  • Would score about 64 if CISA's SSVC rates exploitation active
  • Would score about 29 if advisories confirm default setups are exposed

CVE-2026-121506 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.4 (high) and affects NTPsec; fixed in 1.2.5.

Published
Last modified
Published
Not listed in CISA KEV
24/100 · provisional
Fix
Fixed in 1.2.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

NTPsec, an open-source implementation of the Network Time Protocol used to keep computer clocks synchronized, is affected when it runs as an NTS client. A remote attacker who can send crafted server replies can corrupt memory and crash the time daemon, and in combination with a related flaw, can bypass NTS authentication and set the client's clock to a false time.

Read the original description

An out-of-bounds read and write in NTS client extension field parsing (extens_client_recv) in NTPsec before 1.2.5 allows a remote attacker who can send NTP server-mode replies to an NTS client to corrupt heap memory and crash ntpd, and, combined with the NTS-KE client out-of-bounds read fixed in 1.2.4, to bypass NTS authentication and set the client's time, via an NTS Authenticator and Encrypted Extension Fields field whose nonce length exceeds the field.

What to do

  • Upgrade to a fixed version: 1.2.5.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • NTPsec NTPsec

    From 1.1.4 · fixed in 1.2.5

Evidence 2

  1. Link
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-121506

Is CVE-2026-121506 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-121506?

NTPsec: from 1.1.4 before 1.2.5.Source: cve.now feed data

How do I fix CVE-2026-121506?

Upgrade to a fixed version: 1.2.5.Source: cve.now feed data