Instatic before 0.0.21 Authorization Bypass via MCP Content Read Tools
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 0.0.21
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Instatic versions before 0.0.21 (VulnCheck lists affected versions as >= 0.0.12, < 0.0.21). The attacker must be an authenticated user holding the ai.chat and content.edit.own capabilities.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 15/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 0.0.21
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Instatic, a content management software, is affected before version 0.0.21. Authenticated users with low-level permissions can use its AI/MCP content tools to read other users' private and unpublished draft content, which exposes that data without authorization.
Read the original description
Instatic before 0.0.21 contains a missing authorization vulnerability in its AI/MCP content read tools that allows low-privileged authenticated users with ai.chat and content.edit.own capabilities to access data rows belonging to other users by calling content_get_document and content_list_documents without the object-level authorization checks enforced by the normal HTTP API. Attackers can use the MCP interface to retrieve private or unpublished draft content and enumerate rows from the posts system table, resulting in cross-user data disclosure.
What to do
Check whether your setup matches what the bug needs.
Instatic versions before 0.0.21 (VulnCheck lists affected versions as >= 0.0.12, < 0.0.21). The attacker must be an authenticated user holding the ai.chat and content.edit.own capabilities.Upgrade to a fixed version: 0.0.21.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- CoreBunch Instatic
From 0.0.12 · fixed in 0.0.21
Evidence 3
- Advisory
- Patch
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121458
What does this mean?
An authenticated user with low privileges can use the MCP interface to read other users' private or unpublished draft content and list rows from the posts system table. This lets them see data that belongs to other users.Source: vulncheck.com
Am I affected, and how do I check?
Instatic versions from 0.0.12 up to but not including 0.0.21 are listed as affected. The bug needs an account holding the ai.chat and content.edit.own capabilities, so check your installed Instatic version and the capabilities assigned to your users.Source: vulncheck.com
What should I do about it?
Upgrade Instatic to 0.0.21 or later, which the affected range lists as the fixed version. No other workaround is given in the facts provided.Source: vulncheck.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data