Skip to main content
← Vulnerabilities

Dockhand 1.0.47 before 1.0.54 Secret Disclosure via Git Stack Webhook

7.1HighCNA
Exploited
Proof of concept public, per CISA
Fix
Fixed in 1.0.54
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Affected versions are 1.0.47 up to before 1.0.54 (VulnCheck lists >= 1.0.47, < 1.0.54). A Git stack must have a secret provider or stored secret bound, so that at least one variable resolves to a secret value. For the webhook path, the stack's webhook must be enabled with a secret.

30Pcve.now Index 30 of 100 · methodology v3 · provisional
  • Exploitation15/40CISA rates a proof of concept as public
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity7.1/10CVSS 7.1
  • No patch0/5No signal

What would change the score

  • Would score about 65 if added to CISA KEV
  • Would score about 60 if CISA's SSVC rates exploitation active
  • Would score about 37 if CISA's SSVC rates it automatable

CVE-2026-121449 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects dockhand; fixed in 1.0.54.

Published
Last modified
Published
Not listed in CISA KEV
30/100 · provisional
Specific setups only
Fix
Fixed in 1.0.54
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

Dockhand from 1.0.47 before 1.0.54 exposes plaintext stack secrets because deployStack() attaches resolved secret values to its result as resolvedSecrets, which Git-stack routes return unfiltered. Holders of a stack's webhook secret or users with stacks:start permission can trigger the Git stack webhook, manual deploy, or create-and-deploy endpoints to receive stored and external-provider secrets such as 1Password or Vault values.

What to do

  • Check whether your setup matches what the bug needs.

    Affected versions are 1.0.47 up to before 1.0.54 (VulnCheck lists >= 1.0.47, < 1.0.54). A Git stack must have a secret provider or stored secret bound, so that at least one variable resolves to a secret value. For the webhook path, the stack's webhook must be enabled with a secret.
  • Upgrade to a fixed version: 1.0.54.

  • Workaround: Parse the webhook reply and keep only success, skipped and exitCode; do not print or log reply bodies in scripts and CI.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • Finsys dockhand

    From 1.0.47 · fixed in 1.0.54

Evidence 3

  1. Advisory
  2. Patch
  3. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-121449

Is CVE-2026-121449 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A Git stack's webhook reply can include the plaintext values of that stack's stored and external-provider secrets. Anyone holding the stack's webhook secret, or a user with the stacks:start permission, can receive those values in the HTTP or SSE response.Source: vulncheck.com, github.com

Which versions are affected by CVE-2026-121449?

dockhand: from 1.0.47 before 1.0.54.Source: cve.now feed data

Am I affected, and how do I check?

Dockhand versions 1.0.47 up to but not including 1.0.54 are affected. The bug needs a Git stack with a secret provider or stored secret bound to at least one variable, and the stack's webhook enabled with a secret.Source: vulncheck.com, github.com

How do I fix CVE-2026-121449?

Upgrade Dockhand to 1.0.54 or later. The facts do not list a specific patched version beyond the 1.0.54 boundary given in the affected range.Source: vulncheck.com, github.com