Froxlor 2.3.8 before 2.3.15 API Key Disclosure via api_keys.php
Froxlor versions 2.3.8 through 2.3.14 are affected when an administrator has customers_see_all and api_allowed set to 1 without change_serversettings. Fixed in 2.3.15.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.3.15
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Froxlor versions 2.3.8 through 2.3.14 are affected The administrator account has customers_see_all set to 1 and api_allowed set to 1 The administrator does not have change_serversettings
- Exploitation0/40No signal
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity9.6/10CVSS 8.6, total technical impact per CISA
- No patch0/5No signal
What would change the score
- Would score about 68 if added to CISA KEV
- Would score about 63 if CISA's SSVC rates exploitation active
- Would score about 25 if CISA's SSVC rates it automatable
CVE-2026-121436 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects froxlor; fixed in 2.3.15.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 18/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2.3.15
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Froxlor from 2.3.8 before 2.3.15 contains an information disclosure vulnerability that allows administrators with customers_see_all to view every account's API key and secret through an unscoped WHERE 1 query in api_keys.php. Attackers can read the super administrator's apikey and secret from the detail modal and replay them to the API to gain super administrator control.
What to do
Check whether your setup matches what the bug needs.
Froxlor versions 2.3.8 through 2.3.14 are affected The administrator account has customers_see_all set to 1 and api_allowed set to 1 The administrator does not have change_serversettingsUpgrade to a fixed version: 2.3.15.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- froxlor froxlor
From 2.3.8 · fixed in 2.3.15
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121436
Is CVE-2026-121436 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
An administrator account can read the super administrator's API key and secret from the detail modal on the api_keys.php page. Those credentials can then be used against the API to gain super administrator control.Source: github.com, vulncheck.com
Which versions are affected by CVE-2026-121436?
froxlor: from 2.3.8 before 2.3.15.Source: cve.now feed data
Am I affected, and how do I check?
Froxlor versions 2.3.8 through 2.3.14 are affected. The issue needs an administrator account with customers_see_all set to 1 and api_allowed set to 1, and without change_serversettings, such as an independently configured reseller-type account. The installed version can be checked in the Froxlor panel or in the installation's version files, and the flags are set per administrator account in the admin settings.Source: github.com, vulncheck.com
How do I fix CVE-2026-121436?
Upgrade to Froxlor 2.3.15 or later, which is the listed patched version.Source: github.com, vulncheck.com