Nodemailer 3.0.0 before 10.1.4 Recipient Domain Confusion via addressparser
- Exploited
- No known exploitation
- Fix
- Fixed in 10.1.4
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 10.1.4.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Data gap: Advisories don't say whether default setups are affected
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.3/10CVSS 8.3
- No patch0/5No signal
What would change the score
- Would score about 70 if added to CISA KEV
- Would score about 65 if CISA's SSVC rates exploitation active
- Would score about 30 if advisories confirm default setups are exposed
CVE-2026-121426 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.3 (high) and affects nodemailer; fixed in 10.1.4.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 25/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 10.1.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Nodemailer from 3.0.0 before 10.1.4 contains an address parsing vulnerability in addressparser that ends an angle-addr at a '>' inside a quoted local part, comment or domain literal. Attackers can submit addresses that validate as an allowed domain but are delivered to an attacker-controlled domain, bypassing recipient allow lists and disclosing message content.
What to do
Upgrade to a fixed version: 10.1.4.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- nodemailer nodemailer
From 3.0.0 · fixed in 10.1.4
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121426
Is CVE-2026-121426 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Nodemailer's address parser can be tricked into reading a recipient or sender address as a different domain than intended. Mail the application meant for an allowed domain can then be delivered to a domain the attacker chose, which discloses the message content and bypasses the recipient allow list.Source: github.com
Which versions are affected by CVE-2026-121426?
nodemailer: from 3.0.0 before 10.1.4.Source: cve.now feed data
Am I affected, and how do I check?
Nodemailer versions 3.0.0 through 10.1.3 are affected, and the issue applies only when the application passes user-influenced recipient or sender addresses to Nodemailer. To check, look at the installed Nodemailer version in the project's package.json or by running npm ls nodemailer.Source: github.com
How do I fix CVE-2026-121426?
Upgrade Nodemailer to version 10.1.4 or later, which is the first fixed release. No workaround is given in the checked facts.Source: github.com