Skip to main content
← Vulnerabilities

Nodemailer 3.0.0 before 10.1.4 Recipient Injection via addressparser Group Parsing

8.3HighCNA
Exploited
Proof of concept public, per CISA
Fix
Fixed in 10.1.4
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 10.1.4.

40Pcve.now Index 40 of 100 · methodology v3 · provisional
  • Exploitation15/40CISA rates a proof of concept as public
  • Exposure17/25No login or user action needed, reachable over the network without a login · Data gap: Advisories don't say whether default setups are affected
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity8.3/10CVSS 8.3
  • No patch0/5No signal

What would change the score

  • Would score about 70 if added to CISA KEV
  • Would score about 65 if CISA's SSVC rates exploitation active
  • Would score about 45 if advisories confirm default setups are exposed

CVE-2026-121425 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.3 (high) and affects nodemailer; fixed in 10.1.4.

Published
Last modified
Published
Not listed in CISA KEV
40/100 · provisional
Unclear
Fix
Fixed in 10.1.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

Nodemailer from 3.0.0 before 10.1.4 contains a parsing flaw in addressparser that ends an RFC 5322 group at a semicolon inside quoted display names or comments. Attackers can submit crafted group addresses that conformant validators approve, redirecting mail to attacker-chosen recipients and bypassing recipient allow lists.

What to do

  • Upgrade to a fixed version: 10.1.4.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • nodemailer nodemailer

    From 3.0.0 · fixed in 10.1.4

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-121425

Is CVE-2026-121425 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Nodemailer's address parser mishandles group syntax in recipient lists, so mail meant for an approved recipient can be sent to an attacker-chosen address instead. The intended recipient never gets that mail, and recipient allow lists are bypassed.Source: github.com

Which versions are affected by CVE-2026-121425?

nodemailer: from 3.0.0 before 10.1.4.Source: cve.now feed data

Am I affected, and how do I check?

Nodemailer versions 3.0.0 through 10.1.3 are affected. Check the installed version with npm ls nodemailer. The issue applies to applications that pass user-influenced address lists to Nodemailer, and to users of the standalone parser such as mailparser.Source: github.com

How do I fix CVE-2026-121425?

Upgrade Nodemailer to 10.1.4 or later, which contains the fix. No workaround is listed in the facts.Source: github.com