Nodemailer 3.0.0 before 10.1.4 Address Parsing Bypass via Nested Comments
Affects Nodemailer 3.0.0 through 10.1.3 when applications pass user-influenced addresses to it, or when standalone addressparser users such as mailparser parse such addresses. Fixed in 10.1.4.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 10.1.4
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 10.1.4.
- Exploitation0/40No signal
- Exposure17/25No login or user action needed, reachable over the network without a login · Data gap: Advisories don't say whether default setups are affected
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.3/10CVSS 8.3
- No patch0/5No signal
What would change the score
- Would score about 70 if added to CISA KEV
- Would score about 65 if CISA's SSVC rates exploitation active
- Would score about 30 if advisories confirm default setups are exposed
CVE-2026-121424 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.3 (high) and affects nodemailer; fixed in 10.1.4.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 25/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 10.1.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Nodemailer from 3.0.0 before 10.1.4 contains an address parsing vulnerability in addressparser that allows remote attackers to redirect recipients by ending nested RFC 5322 comments at the first closing parenthesis. Attackers can submit addresses whose nested comment hides an attacker address, bypassing conformant validators and recipient allow lists to receive mail or spoof senders in mailparser.
What to do
Upgrade to a fixed version: 10.1.4.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- nodemailer nodemailer
From 3.0.0 · fixed in 10.1.4
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121424
Is CVE-2026-121424 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The address parser mishandles nested comments in email address fields, so a crafted address can be read differently than intended. Mail meant for an approved recipient can be redirected to an attacker-chosen domain, and parsers built on the module can report a different sender author than conformant parsers, which enables sender spoofing.Source: github.com, vulncheck.com
Which versions are affected by CVE-2026-121424?
nodemailer: from 3.0.0 before 10.1.4.Source: cve.now feed data
Am I affected, and how do I check?
Nodemailer versions 3.0.0 through 10.1.3 are affected. The exposed setups are applications that pass user-influenced addresses to Nodemailer, and consumers of the standalone addressparser such as mailparser. To check a project, look at the installed nodemailer version in its package manifest or lockfile, and check whether any user input reaches address fields.Source: github.com, vulncheck.com
How do I fix CVE-2026-121424?
Upgrade Nodemailer to version 10.1.4 or later. No workaround is listed in the checked facts, so the upgrade is the fix.Source: github.com, vulncheck.com