SurrealDB before 3.3.0 DoS via Unbounded Recursion in val::Value Serialization
Affects SurrealDB versions before 3.3.0 where authenticated users hold ordinary table write and read privileges. The fix is in 3.3.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 3.3.0
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Attacker must be an authenticated user with ordinary table write and read privileges. Affects SurrealDB versions before 3.3.0.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity7.1/10CVSS 7.1
- No patch0/5No signal
What would change the score
- Would score about 65 if added to CISA KEV
- Would score about 60 if CISA's SSVC rates exploitation active
- Would score about 22 if CISA's SSVC rates it automatable
CVE-2026-121423 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects surrealdb; fixed in 3.3.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 15/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 3.3.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
SurrealDB before 3.3.0 contains an unbounded recursion vulnerability that allows authenticated users to abort the surreald process by triggering stack overflow on deeply nested values. Attackers can repeatedly run UPDATE statements wrapping a stored array in itself, then SELECT or EXPORT it, causing persistent denial of service for all tenants.
What to do
Check whether your setup matches what the bug needs.
Attacker must be an authenticated user with ordinary table write and read privileges. Affects SurrealDB versions before 3.3.0.Upgrade to a fixed version: 3.3.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- surrealdb surrealdb
fixed in 3.3.0
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121423
Is CVE-2026-121423 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
An authenticated user with ordinary table write and read privileges can store a record that causes unbounded recursion when SurrealDB serializes it. This crashes the whole surreal process, taking down all namespaces, databases and tenants on the instance, and the stored record triggers the crash again on later reads and exports.Source: github.com, vulncheck.com
Which versions are affected by CVE-2026-121423?
surrealdb: before 3.3.0.Source: cve.now feed data
Am I affected, and how do I check?
SurrealDB versions before 3.3.0 are in the affected range. Exposure also depends on whether authenticated users have ordinary table write and read privileges. Compare the installed SurrealDB version with 3.3.0 to see whether it falls in the affected range.Source: github.com, vulncheck.com
How do I fix CVE-2026-121423?
Upgrade SurrealDB to 3.3.0 or later, which contains the fix. No workaround is listed in the facts.Source: github.com, vulncheck.com