SurrealDB 3.1.0 before 3.3.0 MCP Session Hijack via BoundSubject Collision
- Exploited
- No known exploitation
- Fix
- Fixed in 3.3.0
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Affected SurrealDB versions are 3.1.0 before 3.3.0 (fixed in 3.3.0). The MCP HTTP transport (POST /mcp) must be in use. The deployment uses a database-, namespace- or root-level JWT/BEARER access method serving more than one user.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.6/10CVSS 8.6
- No patch0/5No signal
What would change the score
- Would score about 67 if added to CISA KEV
- Would score about 62 if CISA's SSVC rates exploitation active
- Would score about 24 if CISA's SSVC rates it automatable
CVE-2026-121419 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects surrealdb; fixed in 3.3.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 17/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 3.3.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
SurrealDB from 3.1.0 before 3.3.0 contains an improper authentication vulnerability where the MCP BoundSubject fingerprint uses the access method name instead of per-user identity for JWT/Bearer access. Attackers with a valid low-privilege token for the same access method and a victim's mcp-session-id can hijack the session and execute MCP tools with the victim's roles and permissions.
What to do
Check whether your setup matches what the bug needs.
Affected SurrealDB versions are 3.1.0 before 3.3.0 (fixed in 3.3.0). The MCP HTTP transport (POST /mcp) must be in use. The deployment uses a database-, namespace- or root-level JWT/BEARER access method serving more than one user.Upgrade to a fixed version: 3.3.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- surrealdb surrealdb
From 3.1.0 · fixed in 3.3.0
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121419
Is CVE-2026-121419 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The MCP session binding in SurrealDB can collide between users sharing the same JWT or BEARER access method, so a user holding a valid token for that method can take over another user's MCP session. The attacker then runs MCP tools with the victim's roles and permissions, including changing data the victim can reach.Source: vulncheck.com, github.com
Which versions are affected by CVE-2026-121419?
surrealdb: from 3.1.0 before 3.3.0.Source: cve.now feed data
Am I affected, and how do I check?
SurrealDB versions from 3.1.0 before 3.3.0 are affected, but only when the MCP HTTP transport (POST /mcp) is in use and a database-, namespace- or root-level JWT/BEARER access method serves more than one user. To check, confirm the running version is below 3.3.0 and whether the MCP HTTP endpoint and such an access method are configured.Source: vulncheck.com, github.com
How do I fix CVE-2026-121419?
Upgrade SurrealDB to 3.3.0 or later, which contains the fix.Source: vulncheck.com, github.com