Skip to main content
← Vulnerabilities

Parse Server before 8.6.111 and 9.0.0 before 9.10.6-alpha.3 Field Corruption via Null Dot Notation Key

6.3MediumCNA
Exploited
No known exploitation
Fix
Fixed in 9.10.6-alpha.3, 8.6.111
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 9.10.6-alpha.3, 8.6.111.

23Pcve.now Index 23 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure17/25No login or user action needed per the CVSS vector, reachable over the network without a login · Data gap: No advisory context yet
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity6.3/10CVSS 6.3
  • No patch0/5No signal

What would change the score

  • Would score about 68 if added to CISA KEV
  • Would score about 63 if CISA's SSVC rates exploitation active
  • Would score about 28 if advisories confirm default setups are exposed

CVE-2026-121415 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.3 (medium) and affects parse-server; fixed in 9.10.6-alpha.3 and 8.6.111.

Published
Last modified
Published
Not listed in CISA KEV
23/100 · provisional
Fix
Fixed in 9.10.6-alpha.3, 8.6.111
None on Exploit-DB, Metasploit or GitHub

Summary

Parse Server before 8.6.111 and 9.0.0 before 9.10.6-alpha.3 on MongoDB skips field type validation for null-valued dot notation keys, allowing sub-documents to be written beneath Pointer, Number, String, Date, or Boolean fields. Any client with write access, including unauthenticated clients where public writes are permitted, can corrupt field values, make objects unreadable via internal date fields, or break atomic operations on number fields.

What to do

  • Upgrade to a fixed version: 9.10.6-alpha.3, 8.6.111.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • parse-community parse-server

    From 9.0.0 · fixed in 9.10.6-alpha.3

  • parse-community parse-server

    fixed in 8.6.111

Evidence 4

  1. Advisory
  2. Patch
  3. Patch
  4. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-121415

Is CVE-2026-121415 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-121415?

parse-server: from 9.0.0 before 9.10.6-alpha.3. parse-server: before 8.6.111.Source: cve.now feed data

How do I fix CVE-2026-121415?

Upgrade to a fixed version: 9.10.6-alpha.3, 8.6.111.Source: cve.now feed data