Skip to main content
← Vulnerabilities

Parse Server before 8.6.110 and 9.0.0 before 9.10.6-alpha.2 Denial of Service via afterSave Pointer Update

Parse Server before 8.6.110 and 9.0.0 to before 9.10.6-alpha.2 crashes on classes with an afterSave trigger when an update uses dot notation on a pointer field's object ID. Fixed in 8.6.110 and 9.10.6-alpha.2.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.2HighCNA
Exploited
No known exploitation
Fix
Fixed in 9.10.6-alpha.2, 8.6.110
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Class has an afterSave trigger Object update uses a dot notation key targeting a pointer field's object identifier

20Pcve.now Index 20 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity8.2/10CVSS 8.2
  • No patch0/5No signal

What would change the score

  • Would score about 70 if added to CISA KEV
  • Would score about 65 if CISA's SSVC rates exploitation active

CVE-2026-121414 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.2 (high) and affects parse-server; fixed in 9.10.6-alpha.2 and 8.6.110.

Published
Last modified
Published
Not listed in CISA KEV
20/100 · provisional
Specific setups only
Fix
Fixed in 9.10.6-alpha.2, 8.6.110
None on Exploit-DB, Metasploit or GitHub

Summary

Parse Server before 8.6.110 and 9.0.0 before 9.10.6-alpha.2 fails to contain a serialization error when an object update uses a dot notation key targeting a pointer field's object identifier on a class with an afterSave trigger. Attackers, including unauthenticated clients when objects are writable without a session, can send such an update to crash the Node process.

What to do

  • Check whether your setup matches what the bug needs.

    Class has an afterSave trigger Object update uses a dot notation key targeting a pointer field's object identifier
  • Upgrade to a fixed version: 9.10.6-alpha.2, 8.6.110.

  • Workaround: On affected classes, add a beforeSave trigger that rejects updates whose keys use dot notation to address a pointer field's internal identifier, so the request fails before it reaches the afterSave stage; or remove afterSave triggers from classes that contain pointer fields.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • parse-community parse-server

    From 9.0.0 · fixed in 9.10.6-alpha.2

  • parse-community parse-server

    fixed in 8.6.110

Evidence 4

  1. Advisory
  2. Patch
  3. Patch
  4. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-121414

Is CVE-2026-121414 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

An update that uses dot notation to target a pointer field's object identifier can crash the Parse Server Node process when the class has an afterSave trigger. The crash stops service for all clients until the server is restarted.Source: github.com

Which versions are affected by CVE-2026-121414?

parse-server: from 9.0.0 before 9.10.6-alpha.2. parse-server: before 8.6.110.Source: cve.now feed data

Am I affected, and how do I check?

Parse Server versions before 8.6.110, and 9.0.0 up to but not including 9.10.6-alpha.2. The bug needs a class with an afterSave trigger and an object update that uses a dot notation key on a pointer field's object identifier. Check the parse-server version in your project's package.json or installed package.Source: github.com

How do I fix CVE-2026-121414?

Upgrade to Parse Server 8.6.110 or to 9.10.6-alpha.2 or later. The advisory names upgrading to a patched version as the recommended fix.Source: github.com