Skip to main content
← Vulnerabilities

Parse Server before 8.6.112 and 9.0.0 before 9.10.6-alpha.4 Session Permission Bypass via upgradeToRevocableSession

2.3LowCNA
Exploited
No known exploitation
Fix
Fixed in 9.10.6-alpha.4, 8.6.112
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 9.10.6-alpha.4, 8.6.112.

5Pcve.now Index 5 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure3/25Reachable over the network · Data gap: No advisory context yet
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity2.3/10CVSS 2.3
  • No patch0/5No signal

What would change the score

  • Would score about 60 if added to CISA KEV
  • Would score about 55 if CISA's SSVC rates exploitation active
  • Would score about 24 if advisories confirm default setups are exposed

CVE-2026-121413 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 2.3 (low) and affects parse-server; fixed in 9.10.6-alpha.4 and 8.6.112.

Published
Last modified
Published
Not listed in CISA KEV
5/100 · provisional
Fix
Fixed in 9.10.6-alpha.4, 8.6.112
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Parse Server before 8.6.112 and 9.0.0 before 9.10.6-alpha.4 contains an authorization bypass in the session upgrade endpoint, which creates a new session for any valid session token without enforcing the _Session class create class-level permission. Attackers holding a user's session token can send an already revocable token to /upgradeToRevocableSession to obtain additional sessions with fresh expiration that persist after the original session is logged out.

What to do

  • Upgrade to a fixed version: 9.10.6-alpha.4, 8.6.112.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • parse-community parse-server

    From 9.0.0 · fixed in 9.10.6-alpha.4

  • parse-community parse-server

    fixed in 8.6.112

Evidence 4

  1. Advisory
  2. Patch
  3. Patch
  4. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-121413

Is CVE-2026-121413 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-121413?

parse-server: from 9.0.0 before 9.10.6-alpha.4. parse-server: before 8.6.112.Source: cve.now feed data

How do I fix CVE-2026-121413?

Upgrade to a fixed version: 9.10.6-alpha.4, 8.6.112.Source: cve.now feed data