FreeRDP before 3.32.2 Denial of Service via Oversized X.224 Routing Token
FreeRDP 3.32.1 and earlier are affected, mainly clients redirected by a server and freerdp-proxy with FixedTarget=true, mostly in assertion-enabled builds. Fixed in 3.32.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- Proof of concept public, per CISA
- Fix
- Fixed in 3.32.2
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 3.32.2.
- Exploitation15/40CISA rates a proof of concept as public
- Exposure17/25No login or user action needed, reachable over the network without a login · Data gap: Advisories don't say whether default setups are affected
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.2/10CVSS 8.2
- No patch0/5No signal
What would change the score
- Would score about 70 if added to CISA KEV
- Would score about 65 if CISA's SSVC rates exploitation active
- Would score about 45 if advisories confirm default setups are exposed
CVE-2026-121409 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.2 (high) and affects FreeRDP; fixed in 3.32.2.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 40/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 3.32.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: poc
- Automatable: no
- Technical impact: partial
Summary
FreeRDP before 3.32.2 contains a denial of service vulnerability that allows malicious servers or unauthenticated peers to abort clients or proxies via oversized X.224 routing tokens. Attackers can send an oversized LoadBalanceInfo in a Server Redirection PDU, or a 240–247 byte token to a FixedTarget freerdp-proxy, triggering a tpdu_write_header assertion that crashes the process.
What to do
Upgrade to a fixed version: 3.32.2.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: poc · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- FreeRDP FreeRDP
fixed in 3.32.2
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121409
Is CVE-2026-121409 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
An oversized X.224 routing token, such as an oversized LoadBalanceInfo in a Server Redirection PDU, can make a FreeRDP client or proxy abort. In assertion-enabled builds, the process crashes on a failed assertion, which is a denial of service.Source: github.com, vulncheck.com
Which versions are affected by CVE-2026-121409?
FreeRDP: before 3.32.2.Source: cve.now feed data
Am I affected, and how do I check?
FreeRDP 3.32.1 and earlier are affected. The bug needs a redirect carrying an oversized token of about 240 bytes or more, or a freerdp-proxy configured with FixedTarget=true (or an equivalent module) receiving a 240 to 247 byte token. The advisory says the observed impact is in assertion-enabled builds. Check your installed version with the version output of your FreeRDP build and check the FixedTarget setting in your proxy configuration.Source: github.com, vulncheck.com
How do I fix CVE-2026-121409?
Upgrade to FreeRDP 3.32.2 or later, which contains the fix.Source: github.com, vulncheck.com