Skip to main content
← Vulnerabilities

FreeRDP before 3.32.2 Certificate Identity Validation Bypass via tls_verify_certificate

FreeRDP before 3.32.2 is affected when the client trusts the CA that issued an attacker's certificate, and the facts describe a separate IP-literal target case. Fixed in 3.32.2.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

9.1CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 3.32.2
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 3.32.2.

27Pcve.now Index 27 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure17/25No login or user action needed, reachable over the network without a login · Data gap: Advisories don't say whether default setups are affected
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity10/10CVSS 9.1, total technical impact per CISA
  • No patch0/5No signal

What would change the score

  • Would score about 72 if added to CISA KEV
  • Would score about 67 if CISA's SSVC rates exploitation active
  • Would score about 32 if advisories confirm default setups are exposed

CVE-2026-121392 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.1 (critical) and affects FreeRDP; fixed in 3.32.2.

Published
Last modified
Published
Not listed in CISA KEV
27/100 · provisional
Unclear
Fix
Fixed in 3.32.2
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

FreeRDP, an open-source implementation of the Remote Desktop Protocol, is affected because it incorrectly validates server certificates, letting an attacker with a certificate from a trusted authority impersonate the server. A successful man-in-the-middle attack could allow the attacker to intercept remote desktop sessions, including typed keystrokes, clipboard contents, and screen data.

Read the original description

FreeRDP before 3.32.2 contains an improper certificate validation vulnerability in tls_verify_certificate() that accepts Common Name fallback despite non-matching SAN entries and matches IP literals against DNS strings. Man-in-the-middle attackers holding a certificate from a client-trusted CA can bypass server identity checks to intercept RDP sessions, including keystrokes, clipboard, and screen content.

What to do

  • Upgrade to a fixed version: 3.32.2.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now
  4. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  5. Record last updated

Affected versions

  • FreeRDP FreeRDP

    fixed in 3.32.2

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-121392

Is CVE-2026-121392 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

FreeRDP can fail to properly verify the server's identity certificate. A man-in-the-middle can silently bypass server identity verification and intercept the RDP session, including screen content, keystrokes, clipboard, and input injection.Source: github.com, vulncheck.com

Which versions are affected by CVE-2026-121392?

FreeRDP: before 3.32.2.Source: cve.now feed data

Am I affected, and how do I check?

FreeRDP versions before 3.32.2 are affected. The conditions listed are a client that trusts the CA that issued the attacker's certificate, and, for the IP-literal case, an RDP target given as an IP address. Compare the installed FreeRDP version against 3.32.2 and check the trusted CA setup of the client.Source: github.com, vulncheck.com

How do I fix CVE-2026-121392?

Upgrade FreeRDP to 3.32.2 or later, which contains the fix.Source: github.com, vulncheck.com