Skip to main content
← Vulnerabilities

Tanium addressed a heap-based buffer overflow vulnerability in Deploy.

Affects Tanium Deploy 2.36.0 to 2.36.294, 2.40.0 to 2.40.235 and 2.45.0 to 2.45.322, fixed in the matching builds.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.2HighCNA
Exploited
No known exploitation
Fix
Fixed in 2.45.322, 2.40.235, 2.36.294
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Deploy is in a prior-to-fixed version in the 2025H1, 2025H2 or 2026H1 release lines Attacker must be an authenticated Tanium user holding the Deploy Software Package write permission

15Pcve.now Index 15 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity7.2/10CVSS 7.2
  • No patch0/5No signal

What would change the score

  • Would score about 65 if added to CISA KEV
  • Would score about 60 if CISA's SSVC rates exploitation active
  • Would score about 22 if CISA's SSVC rates it automatable

CVE-2026-120775 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.2 (high) and affects Deploy; fixed in 2.45.322, 2.40.235 and 2.36.294.

Published
Last modified
Published
Not listed in CISA KEV
15/100 · provisional
Specific setups only
Fix
Fixed in 2.45.322, 2.40.235, 2.36.294
None on Exploit-DB, Metasploit or GitHub

Summary

Tanium Deploy, a software deployment and patch management product, is affected by a heap-based buffer overflow vulnerability. An attacker who exploits this flaw could potentially corrupt memory and may be able to crash the software or run malicious code.

Read the original description

Tanium addressed a heap-based buffer overflow vulnerability in Deploy.

What to do

  • Check whether your setup matches what the bug needs.

    Deploy is in a prior-to-fixed version in the 2025H1, 2025H2 or 2026H1 release lines Attacker must be an authenticated Tanium user holding the Deploy Software Package write permission
  • Upgrade to a fixed version: 2.45.322, 2.40.235, 2.36.294.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • Tanium Deploy

    From 2.45.0 · fixed in 2.45.322; From 2.40.0 · fixed in 2.40.235; From 2.36.0 · fixed in 2.36.294

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-120775

Is CVE-2026-120775 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The bug is a heap-based buffer overflow in Tanium Deploy, which can let unauthorized code run in the context of Deploy.Source: security.tanium.com

Which versions are affected by CVE-2026-120775?

Deploy: from 2.45.0 before 2.45.322; from 2.40.0 before 2.40.235; from 2.36.0 before 2.36.294.Source: cve.now feed data

Am I affected, and how do I check?

Affected builds are Deploy 2.36.0 to 2.36.294, 2.40.0 to 2.40.235 and 2.45.0 to 2.45.322, covering the 2025H1, 2025H2 and 2026H1 release lines. Compare the installed Deploy version against these ranges. The flaw requires an authenticated Tanium user with the Deploy Software Package write permission.Source: security.tanium.com

How do I fix CVE-2026-120775?

Upgrade Deploy to the fixed build for its release line: 2.36.294, 2.40.235 or 2.45.322.Source: security.tanium.com