Skip to main content
← Vulnerabilities

CGI versions from 4.71 before 5.00 for Perl allow denial of service via a plain string dereferenced as a symbolic reference in uploadInfo

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

—Not rated
Exploited
No known exploitation
Fix
Fixed in 5.00
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 5.00.

0Pcve.now Index 0 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure?/25Exposure: unknown (data gap). No advisory context yet
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity?/10Severity: unknown (data gap). No CVSS score or vendor rating
  • No patch0/5No signal

What would change the score

  • Would score about 55 if added to CISA KEV
  • Would score about 50 if CISA's SSVC rates exploitation active
  • Would score about 22 if advisories confirm default setups are exposed

CVE-2026-120646 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects CGI; fixed in 5.00.

Published
Last modified
Published
Not listed in CISA KEV
0/100 · provisional
Fix
Fixed in 5.00
None on Exploit-DB, Metasploit or GitHub

Summary

The CGI module for Perl (versions 4.71 up to, but not including, 5.00) is affected. A specially crafted request parameter can cause the uploadInfo function to crash, resulting in a denial of service for the application that uses it.

Read the original description

CGI versions from 4.71 before 5.00 for Perl allow denial of service via a plain string dereferenced as a symbolic reference in uploadInfo. uploadInfo dereferences its argument and calls its filename method without checking that it is an upload filehandle. A plain string naming a defined global variable, such as the parameter value from ?upload=0, is treated as a symbolic reference, and the method call on it dies.

What to do

  • Upgrade to a fixed version: 5.00.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • CGI

    From 4.71 · fixed in 5.00

Evidence 3

  1. Patch
  2. Link
  3. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-120646

Is CVE-2026-120646 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-120646?

CGI: from 4.71 before 5.00.Source: cve.now feed data

How do I fix CVE-2026-120646?

Upgrade to a fixed version: 5.00.Source: cve.now feed data