CGI versions from 4.62 before 5.00 for Perl allow cross-site scripting via a raw apostrophe in URLs returned by url and self_url
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 5.00
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 5.00.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure?/25Exposure: unknown (data gap). No advisory context yet
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity?/10Severity: unknown (data gap). No CVSS score or vendor rating
- No patch0/5No signal
What would change the score
- Would score about 55 if added to CISA KEV
- Would score about 50 if CISA's SSVC rates exploitation active
- Would score about 22 if advisories confirm default setups are exposed
CVE-2026-120643 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects CGI; fixed in 5.00.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 0/100 · provisional
- Fix
- Fixed in 5.00
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The CGI module for Perl, in versions from 4.62 before 5.00, is affected. It can let attackers inject malicious scripts into web pages when applications place the URLs returned by its url and self_url functions inside single-quoted HTML attributes or JavaScript strings, which could allow cross-site scripting attacks against users.
Read the original description
CGI versions from 4.62 before 5.00 for Perl allow cross-site scripting via a raw apostrophe in URLs returned by url and self_url. Both pass the URL through URI's canonical method, which leaves an apostrophe in the path raw and decodes the %27 that query parameter escaping produces, so an apostrophe in the request path or a parameter appears raw in the result. An application that places the URL in a single-quoted HTML attribute or JavaScript string is open to cross-site scripting.
What to do
Upgrade to a fixed version: 5.00.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- CGI
From 4.62 · fixed in 5.00
Evidence 3
- Patch
- Link
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-120643
Is CVE-2026-120643 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-120643?
CGI: from 4.62 before 5.00.Source: cve.now feed data
How do I fix CVE-2026-120643?
Upgrade to a fixed version: 5.00.Source: cve.now feed data