Skip to main content
← Vulnerabilities

Welcart e-Commerce Plugin paymentESCOTT.main.class.php error_page_message cross site scripting

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

5.3MediumCNA
Exploited
No known exploitation
Fix
Fix or patch referenced
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. e-SCOTT Smart (ESCOTT) settlement must be activated

Published
Last modified
Published
Not listed in CISA KEV
17/100 · provisional
Specific setups only
Fix
Fix or patch referenced
None on Exploit-DB, Metasploit or GitHub

Summary

The Welcart e-Commerce plugin for WordPress, an online store plugin, is affected by a cross-site scripting flaw in its payment handling code for the ESCOTT payment method. An attacker can exploit this remotely by manipulating a response parameter so that malicious scripts run in a visitor's browser, potentially allowing session hijacking or actions performed as the victim.

Read the original description

A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

What to do

  • Check whether your setup matches what the bug needs.

    e-SCOTT Smart (ESCOTT) settlement must be activated
  • Apply the patch listed under Evidence.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • Welcart e-Commerce Plugin

    2.12.0, 2.12.1, 2.12.2, 2.12.3, 2.12.4, 2.12.5, 2.12.6

Evidence 6

  1. Advisory
  2. Advisory
  3. Advisory
  4. Advisory
  5. Patch
  6. Exploit

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-120597

What does this mean?

The flaw is a cross-site scripting issue in the error_page_message handling of the paymentESCOTT.main.class.php file, which is the e-SCOTT Smart payment code. Cross-site scripting lets a page show attacker-supplied script in a visitor's browser.Source: github.com

Am I affected, and how do I check?

The affected setup is sites with the e-SCOTT Smart (ESCOTT) settlement activated in Welcart e-Commerce Plugin. No affected version range is listed in the available facts, so a reader can check whether that settlement is enabled in the plugin's payment settings and compare their plugin version with the vendor's advisory.Source: github.com

What should I do about it?

The available facts name no fixed version or workaround. Check the vendor's advisory for an updated plugin release and install it when it is published.Source: github.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data