Skip to main content
← Vulnerabilities

QuickJS-NG before 0.16.0 Heap Buffer Overflow via Proxy ownKeys Enumeration

QuickJS-NG versions before 0.16.0 on 32-bit hosts, such as IoT devices, embedded systems and WASM runtimes, are covered by this heap overflow. Fixed in 0.16.0.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.5HighCNA
Exploited
No known exploitation
Fix
Fixed in 0.16.0
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Runs on a 32-bit host; the overflow does not occur on 64-bit platforms

Published
Last modified
Published
Not listed in CISA KEV
14/100 · provisional
Specific setups only
Fix
Fixed in 0.16.0
None on Exploit-DB, Metasploit or GitHub

Summary

QuickJS-NG, a lightweight JavaScript engine used to run JavaScript code, is affected on 32-bit systems when handling Proxy objects. An attacker who can run JavaScript could trigger a memory overflow that may crash the application or potentially allow execution of attacker-supplied code.

Read the original description

QuickJS-NG before 0.16.0 contains an integer overflow in js_proxy_get_own_property_names() in quickjs.c that causes a heap buffer overflow on 32-bit hosts. Attackers running JavaScript can return a large array-like object from a Proxy ownKeys trap to wrap the allocation size, causing crashes or potential code execution.

What to do

  • Check whether your setup matches what the bug needs.

    Runs on a 32-bit host; the overflow does not occur on 64-bit platforms
  • Upgrade to a fixed version: 0.16.0.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • quickjs-ng QuickJS-NG

    fixed in 0.16.0

Evidence 5

  1. Advisory
  2. Patch
  3. Repository
  4. Repository
  5. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-120438

What does this mean?

A Proxy's ownKeys enumeration can write past the end of a heap buffer in QuickJS-NG. The corrupted heap metadata may allow crashes or code execution.Source: github.com

Am I affected, and how do I check?

The affected range is QuickJS-NG versions before 0.16.0, and the overflow is described as occurring on 32-bit platforms, not 64-bit ones. To check a setup, look at the QuickJS-NG version in use and the platform it runs on.Source: github.com

What should I do about it?

Upgrade QuickJS-NG to 0.16.0 or later.Source: github.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data