Skip to main content
← Vulnerabilities

Netpbm before 10.86.51, 11.02.29, and 11.15.07 sgitopnm Heap Buffer Overflow

Affects Netpbm builds before 10.86.51, 11.02.29, and 11.15.07 when sgitopnm processes corrupted RLE-compressed SGI input. Fixed in releases 10.86.51, 11.02.29, and 11.15.07.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.5HighCNA
Exploited
No known exploitation
Fix
Fixed in 10.86.51, 11.02.29, 11.15.07
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Processing corrupted RLE-compressed SGI input with sgitopnm The offset table specifies an invalidly long file data length for a line

Published
Last modified
Published
Not listed in CISA KEV
14/100 · provisional
Specific setups only
Fix
Fixed in 10.86.51, 11.02.29, 11.15.07
None on Exploit-DB, Metasploit or GitHub

Summary

Netpbm, a widely used open-source toolkit for manipulating image files, is affected through its sgitopnm converter when it processes certain compressed SGI image files. A specially crafted file can overflow a memory buffer, which could crash the program or potentially allow an attacker to run malicious code.

Read the original description

Netpbm before 10.86.51, 11.x before 11.02.29, and 11.03 before 11.15.07 contains a heap-based buffer overflow in sgitopnm's readChannels() function when processing RLE-compressed SGI images. Attackers can supply crafted SGI files with oversized offset table lengths to write controlled data past the heap buffer, causing crashes or potential code execution.

What to do

  • Check whether your setup matches what the bug needs.

    Processing corrupted RLE-compressed SGI input with sgitopnm The offset table specifies an invalidly long file data length for a line
  • Upgrade to a fixed version: 10.86.51, 11.02.29, 11.15.07.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • Netpbm Netpbm

    fixed in 10.86.51; From 11.0 · fixed in 11.02.29; From 11.03 · fixed in 11.15.07

Evidence 6

  1. Patch
  2. Link
  3. Link
  4. Link
  5. Link
  6. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-120431

What does this mean?

sgitopnm can write past the end of a heap buffer when it reads corrupted RLE-compressed SGI input. The offset table in the file can state an invalidly long data length for a line, which corrupts memory when crafted input is read.Source: svn.code.sf.net, sourceforge.net

Am I affected, and how do I check?

Netpbm versions before 10.86.51, from 11.00 up to before 11.02.29, and from 11.03 up to before 11.15.07 are in the affected ranges. Check the installed Netpbm version and whether sgitopnm is used on RLE-compressed SGI files.Source: svn.code.sf.net, sourceforge.net

What should I do about it?

Upgrade to the fixed release for your version line: 10.86.51, 11.02.29, or 11.15.07. The advisory's fix release listed is 11.02.29.Source: svn.code.sf.net, sourceforge.net

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data