Network-AI 5.13.4 before 5.15.5 Path Traversal via AgentVCR Cassette Name
Only affects Network-AI 5.13.4 before 5.15.5 in apps that pass a caller-controlled name to AgentVCR load() or save(). Fixed in 5.15.5.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 5.15.5
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Network-AI versions from 5.13.4 before 5.15.5 (affected range >= 5.13.4, <= 5.15.4 per the GHSA) The application must pass a caller-influenced name to AgentVCR load() or save()
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 17/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 5.15.5
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Network-AI, a framework for coordinating AI agents, is affected by a path traversal flaw in its AgentVCR component. An attacker who can control the cassette name could read sensitive JSON data or overwrite policy files, such as AuthGuardian trust-level settings, potentially disclosing information and weakening access controls.
Read the original description
Network-AI from 5.13.4 before 5.15.5 contains a path traversal vulnerability in AgentVCR that allows attackers controlling the cassette name to read or write arbitrary .json files. Attackers can pass traversal sequences to load() or save() to disclose sensitive JSON data or overwrite policy files such as AuthGuardian trust-level configuration.
What to do
Check whether your setup matches what the bug needs.
Network-AI versions from 5.13.4 before 5.15.5 (affected range >= 5.13.4, <= 5.15.4 per the GHSA) The application must pass a caller-influenced name to AgentVCR load() or save()Upgrade to a fixed version: 5.15.5.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- Jovancoding Network-AI
From 5.13.4 · fixed in 5.15.5
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-120312
What does this mean?
A caller who controls the cassette name can make Network-AI read or write arbitrary .json files on the system, within the process's filesystem permissions. Reading can expose sensitive JSON data, and writing can overwrite files such as AuthGuardian trust-level policy files.Source: vulncheck.com, github.com
Am I affected, and how do I check?
Network-AI versions from 5.13.4 before 5.15.5 are affected, per the GHSA range >= 5.13.4, <= 5.15.4. The exposure also requires an application that passes a caller-influenced name argument to AgentVCR.load() or AgentVCR.save(); check the installed Network-AI version and whether that code path exists in your setup.Source: vulncheck.com, github.com
What should I do about it?
Upgrade Network-AI to 5.15.5 or later, which is the first fixed version listed.Source: vulncheck.com, github.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data