Skip to main content
← Vulnerabilities

Network-AI 5.13.4 before 5.15.5 Path Traversal via FileJobStore Job ID

Affects network-ai 5.13.4 through 5.15.4 in applications that instantiate FileJobStore and expose job lookup or cancellation. Fixed in 5.15.5.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.7HighCNA
Exploited
No known exploitation
Fix
Fixed in 5.15.5
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Affected versions are 5.13.4 through 5.15.4 of the network-ai npm package. A consuming application must instantiate the store and expose job lookup or cancellation.

Published
Last modified
Published
Not listed in CISA KEV
17/100 · provisional
Specific setups only
Fix
Fixed in 5.15.5
None on Exploit-DB, Metasploit or GitHub

Summary

Network-AI, an AI agent orchestration framework, is affected by a path traversal flaw in its FileJobStore component that lets an attacker who controls a job ID read or delete arbitrary JSON files on the system. Successful exploitation could expose credentials and grant tokens, or remove configuration files, weakening the AuthGuardian authorization controls.

Read the original description

Network-AI from 5.13.4 before 5.15.5 contains a path traversal vulnerability in FileJobStore that allows attackers to read or delete arbitrary .json files by supplying traversal sequences in the job id. Attackers controlling the id passed to FileJobStore.get(), FileJobStore.delete(), or JobQueue.getJob() can disclose credentials and grant tokens or delete configuration files to weaken AuthGuardian authorization.

What to do

  • Check whether your setup matches what the bug needs.

    Affected versions are 5.13.4 through 5.15.4 of the network-ai npm package. A consuming application must instantiate the store and expose job lookup or cancellation.
  • Upgrade to a fixed version: 5.15.5.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • Jovancoding Network-AI

    From 5.13.4 · fixed in 5.15.5

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-120311

What does this mean?

A crafted job ID can make the FileJobStore read arbitrary .json files and return their parsed contents, which may include credentials and grant tokens. It can also delete arbitrary .json files, such as configuration files, which weakens AuthGuardian authorization.Source: github.com, vulncheck.com

Am I affected, and how do I check?

Affected versions are 5.13.4 through 5.15.4 of the network-ai npm package. Check the installed version with npm ls network-ai, and check whether the consuming application instantiates the store and exposes job lookup or cancellation.Source: github.com, vulncheck.com

What should I do about it?

Upgrade the network-ai npm package to 5.15.5, which is the fixed version. No workaround is listed in the facts.Source: github.com, vulncheck.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data