@fastify/http-proxy vulnerable to prefix escape via decoded route parameters
Only @fastify/http-proxy 9.0.0 up to 11.6.6 that uses parameterized prefix and rewritePrefix options to pin clients to a fixed upstream path is covered. The fix is in 11.6.6.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 11.6.6
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 11.6.6.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 20/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 11.6.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: total
Summary
The @fastify/http-proxy plugin for Fastify, when configured with parameterized prefix and rewritePrefix options, lets unauthenticated remote attackers craft encoded route parameters that escape the intended upstream path. This can allow access to upstream resources outside the restricted prefix, potentially enabling server-side request forgery or authorization bypass in the proxied service.
Read the original description
@fastify/http-proxy is a Fastify plugin that proxies HTTP requests to an upstream server under a configured prefix. In versions 9.0.0 through 11.6.5, when an application uses parameterized prefix and rewritePrefix options to pin clients to a fixed upstream path, the plugin substitutes URL-decoded route parameters into rewritePrefix without re-encoding them. A parameter value that encodes a path separator together with a fragment or query delimiter therefore decodes into real separators and delimiters that inject extra upstream path segments and strip the mandatory suffix the rewritePrefix was meant to enforce, without using any dot-dot traversal. An unauthenticated remote attacker can use this to reach upstream locations outside the intended prefix, leading to path-restriction bypass and, depending on the upstream, server-side request forgery or authorization bypass in the proxied service. The issue is fixed in @fastify/http-proxy 11.6.6, and users should upgrade to 11.6.6 or later. There is no workaround other than upgrading.
What to do
Upgrade to a fixed version: 11.6.6.
Timeline
- CVE published
- First seen by cve.now
- Posted on X by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: total
- Record last updated
Affected versions
- @fastify/http-proxy @fastify/http-proxy
From 9.0.0 · fixed in 11.6.6
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-120213
What does this mean?
A route parameter decoded from the request can push the proxied path outside the prefix the application meant to pin clients to. This lets requests reach upstream locations the restriction was supposed to block.Source: github.com
Am I affected, and how do I check?
Versions 9.0.0 up to but not including 11.6.6 are in range, but only where the application sets parameterized prefix and rewritePrefix options to pin clients to a fixed upstream path. Check the installed version with npm ls @fastify/http-proxy, and check the proxy registration for route parameters such as :name in prefix or rewritePrefix.Source: github.com
What should I do about it?
Upgrade @fastify/http-proxy to 11.6.6 or later. The advisory gives no workaround.Source: github.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data