Temporal Server Kubernetes compute provider builds a client from caller-supplied configuration and runs a caller-chosen command on the…
Temporal Server 1.31.0 to 1.31.4 and 1.32.0 to 1.32.1 are affected when the Kubernetes compute provider is compiled in without the computeprovider_k8s build-tag gate. Fixed in 1.31.5 and 1.32.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 1.31.5, 1.32.2
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Kubernetes compute provider was compiled into builds without a build-tag gate
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 17/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 1.31.5, 1.32.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Temporal Server's Worker Service, specifically its Kubernetes compute provider, can be made to run an attacker-chosen command on the host under the server's account. An authenticated user with only a read role in a single namespace could trigger this, potentially compromising the persistence credentials and TLS material for the whole cluster.
Read the original description
Temporal Server compiles a Worker Controller Instance module, go.temporal.io/auto-scaled-workers, into its Worker Service, and that module registers a compute provider named k8s whose function is to manage workers running in a Kubernetes cluster. The k8s provider built its Kubernetes client from the client configuration supplied in the caller's request rather than from operator configuration, and building and using that client could run a command of the caller's choosing on the Worker Service host, under the account the server process runs as. Two frontend operations reach the provider. CreateWorkerDeploymentVersion requires a namespace write role. ValidateWorkerDeploymentVersionComputeConfig is registered as a read-only namespace operation, so an authenticated caller holding only a read role in a single namespace can reach the provider through it, and that route does not require a worker deployment to already exist. Execution happens while the submitted configuration is validated, so no scaling decision, task arrival, or unusual request sequence is required. Because the Worker Service process holds the persistence credentials for every namespace in the cluster and the cluster's TLS material, the consequence reaches beyond the caller's namespace to the cluster as a whole. The provider is present in the official temporal-server binaries and container images for the affected releases. The control that keeps it unreachable is the compute provider allowlist, the dynamic configuration setting workercontroller.compute_providers.enabled. On Temporal Server 1.31.0 through 1.31.2 that allowlist does not deny by default: when the setting is unset the check is skipped and every registered compute provider is permitted, k8s included, so a stock deployment of those releases is exposed. On 1.31.3 and later 1.31 releases, and on 1.32.0 and later 1.32 releases, the allowlist denies by default, and a deployment is exposed only where k8s has been added to it. The 1.30 release line does not include the Worker Controller Instance module and is unaffected. To determine whether a deployment is affected, check the following together. The deployed Temporal Server version is in an affected range. The Worker Service is running, which it is in the default service set and therefore in a stock deployment. The effective value of workercontroller.compute_providers.enabled contains k8s, or, on 1.31.0 through 1.31.2 only, is unset; check both the global value and every namespace-constrained override, because an override can add k8s for a single namespace. And authorization is configured, meaning a real authorizer and claim mapper are in place; a deployment running with no authorizer already grants every caller unrestricted access to every namespace, so it has no namespace boundary for this to cross. Deployments that use a custom authorizer should also check whether it permits ValidateWorkerDeploymentVersionComputeConfig to callers without namespace write access. The separate per-namespace dynamic configuration setting workercontroller.enabled does not gate the affected path on any affected release.
What to do
Check whether your setup matches what the bug needs.
Kubernetes compute provider was compiled into builds without a build-tag gateUpgrade to a fixed version: 1.31.5, 1.32.2.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- go.temporal.io/server
From 1.31.0 · fixed in 1.31.5; From 1.32.0 · fixed in 1.32.2
Evidence 5
- Patch
- Patch
- Repository
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-120091
What does this mean?
The Kubernetes compute provider builds a client from configuration supplied by the caller and runs a command the caller chooses. The provider is compiled into affected builds without a build-tag gate.Source: github.com
Am I affected, and how do I check?
Temporal Server 1.31.0 through 1.31.4 and 1.32.0 through 1.32.1 are in the affected ranges. Builds where the Kubernetes compute provider was compiled in without the computeprovider_k8s build tag are the affected setup. Check your server version and whether the computeprovider_k8s build tag was used when the binary was built.Source: github.com
What should I do about it?
Upgrade to Temporal Server 1.31.5 if you are on the 1.31 line, or to 1.32.2 if you are on the 1.32 line. Both fixed versions are listed in the advisory ranges.Source: github.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data