Skip to main content
← Vulnerabilities

Gst-plugins-good: assertion failures in FLV demuxer when parsing malformed enhanced audio/video tags

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

6.5MediumCNA
Exploited
No known exploitation
Fix
Fixed in 1.28.2
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 1.28.2.

24Pcve.now Index 24 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure7/25Reachable over the network without a login · Data gap: No advisory context yet
  • Reach10/20Shipped in major Linux distributions
  • Severity6.5/10CVSS 6.5
  • No patch0/5No signal

What would change the score

  • Would score about 79 if added to CISA KEV
  • Would score about 74 if CISA's SSVC rates exploitation active
  • Would score about 39 if advisories confirm default setups are exposed

CVE-2026-119843 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.5 (medium) and affects Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8 and 2 more; fixed in 1.28.2.

Published
Last modified
Published
Not listed in CISA KEV
0.56% · 46th percentile
24/100 · provisional
Fix
Fixed in 1.28.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

GStreamer's gst-plugins-good package, which handles FLV media demuxing, is affected. A specially crafted or truncated FLV file can cause a GStreamer-based application to crash or fail an internal assertion, resulting in a denial of service.

Read the original description

A flaw was found in GStreamer's gst-plugins-good package. The FLV media demuxer does not properly validate buffer sizes and data availability when processing enhanced audio and video tags in malformed or truncated FLV streams. A remote attacker could exploit this vulnerability by providing a specially crafted FLV media file that, when opened or streamed by a GStreamer-based application, triggers an assertion failure or a process crash, leading to denial of service.

What to do

  • Upgrade to a fixed version: 1.28.2.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • gstreamer1-plugins-good

    Version range not reported

  • gstreamer1-plugins-good

    Version range not reported

  • gstreamer1-plugins-good

    Version range not reported

  • gstreamer1-plugins-good

    Version range not reported

  • GStreamer project gst-plugins-good

    fixed in 1.28.2

Evidence 4

  1. Report
  2. Link
  3. Link
  4. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-119843

Is CVE-2026-119843 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-119843?

gst-plugins-good: before 1.28.2.Source: cve.now feed data

How do I fix CVE-2026-119843?

Upgrade to a fixed version: 1.28.2.Source: cve.now feed data