Gstreamer1-plugins-bad-free: gstreamer1-plugins-bad-free: stack buffer overflow in h.266/vvc parser
Affects gst-plugins-bad H.266/VVC parsing in versions 1.25.1 through before 1.28.2, including gstreamer1-plugins-bad-free in RHEL 10.2.z, 10.3.z, 10.4, RHIVOS 2.1 and Fedora 43. Fixed in 1.28.2.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 1.28.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
The GStreamer "bad" plugins package (gst-plugins-bad), used by applications that play or process media, is affected when parsing H.266/VVC video. A malformed file or stream can trigger a stack buffer overflow that may crash the application or potentially allow an attacker to run code within it.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
A flaw was found in GStreamer's gst-plugins-bad H.266/VVC parser. When processing a malformed H.266 media file or stream, an integer overflow while parsing profile, tier, and level fields can lead to a stack-based buffer overflow. An attacker could cause an application to crash and may be able to execute code in the context of the affected application.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- gstreamer1-plugins-bad-free
Version range not reported
- gstreamer1-plugins-bad-free
Version range not reported
- gstreamer1-plugins-bad-free
Version range not reported
- gstreamer1-plugins-bad-free
Version range not reported
References 3
access.redhat.com
bugzilla.redhat.com
gitlab.freedesktop.org
Questions about CVE-2026-119777
What does this mean?
A flaw in the H.266/VVC video parser of GStreamer's bad-plugins set writes past the end of a buffer on the stack. A crafted H.266/VVC file or stream can crash the application that processes it and may allow code execution with that application's privileges.Source: bugzilla.redhat.com, access.redhat.com
Am I affected, and how do I check?
Upstream lists gst-plugins-bad versions 1.25.1 through before 1.28.2 as affected. Red Hat lists gstreamer1-plugins-bad-free in RHEL 10.2.z, 10.3.z and 10.4, RHIVOS 2.1 and 2.1-core, and Fedora 43 as affected. Exposure also requires a GStreamer-based application that opens or ingests H.266/VVC media; check the gst-plugins-bad version with the package manager and whether the application uses that codec.Source: bugzilla.redhat.com, access.redhat.com
What should I do about it?
Upgrade gst-plugins-bad to version 1.28.2 or later, which contains the fix. If an upgrade is not possible yet, disable H.266/VVC media ingestion in GStreamer-based applications and pipelines where it is not required.Source: bugzilla.redhat.com, access.redhat.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data