BTCPay Server < 2.4.2 LND Macaroon Credential File Disclosure
Only BTCPay Server before 2.4.2, including 2.4.2 release candidates, is affected when it uses LND as its Lightning implementation. Fixed in 2.4.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.4.2
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 2.4.2.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
BTCPay Server versions before 2.4.2 (including the 2.4.2 release candidates) can be attacked remotely, without logging in, to retrieve LND macaroon credential files. An attacker who obtains such a macaroon can take full control of the LND node, including moving funds out of affected deployments.
Read the original description
BTCPay Server before 2.4.2, including 2.4.2 release candidates, contains an information disclosure vulnerability that allows unauthenticated remote attackers to retrieve .macaroon credential files for an LND (Lightning Network Daemon) node. Attackers can use the exposed macaroon to gain full control of the LND node, including moving funds, resulting in theft of funds from affected deployments.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
- Reach?/20Unknown. No tracked technology or package matched
- Severity9.3/10CVSS 9.3
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 2.4.2.
Workaround: If you use LND and cannot update right away, take the server offline until you can.
Timeline
- CVE published
- First seen by cve.now
- Posted on X by cve.now
Affected versions
- BTCPay Server BTCPay Server
fixed in 2.4.2
Evidence 3
- Patch
- Link
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-119757
Is CVE-2026-119757 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The flaw can expose LND .macaroon credential files from BTCPay Server. Those credentials could be used to take control of an LND node and move its funds.Source: blog.btcpayserver.org, vulncheck.com
Which versions are affected by CVE-2026-119757?
BTCPay Server: before 2.4.2.Source: cve.now feed data
Am I affected, and how do I check?
BTCPay Server versions before 2.4.2, including 2.4.2 release candidates, are affected when LND is the Lightning implementation. Check the BTCPay Server version in the server's settings and whether LND is the Lightning backend in use.Source: blog.btcpayserver.org, vulncheck.com
How do I fix CVE-2026-119757?
Update to BTCPay Server 2.4.2 and LND 0.21.1. If an update cannot be applied right away, take the server offline until it can be updated.Source: blog.btcpayserver.org, vulncheck.com