GetPaid WordPress Plugin < 2.8.63 Authorization Bypass via maybe_use_invoice
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.8.63
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 2.8.63.
- Exploitation0/40No signal
- Exposure20/25No login or user action needed per the CVSS vector, CISA rates it automatable · Data gap: No advisory context yet
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity6.9/10CVSS 6.9
- No patch0/5No signal
What would change the score
- Would score about 72 if added to CISA KEV
- Would score about 67 if CISA's SSVC rates exploitation active
- Would score about 32 if advisories confirm default setups are exposed
CVE-2026-119748 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.9 (medium) and affects Payment forms, Buy now buttons, and Invoicing System | GetPaid; fixed in 2.8.63.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 27/100 · provisional
- Fix
- Fixed in 2.8.63
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
The GetPaid WordPress plugin contains an authorization bypass that lets an unauthenticated attacker over the network view another user's pending invoice and start a checkout that changes its status to on-hold. The flaw can be reached remotely, without logging in, by supplying a known invoice ID through the maybe_use_invoice parameter.
Read the original description
The GetPaid plugin for WordPress before 2.8.63 contains an authorization bypass vulnerability that allows unauthenticated attackers to access and manipulate another user's invoice by supplying its ID through the maybe_use_invoice parameter in process_invoice(), bypassing the ownership and key checks performed by is_authorized_to_pay(). Attackers can submit a known pending invoice ID via maybe_use_invoice to read checkout pricing details and initiate a checkout workflow, resulting in an unauthorized state change of the invoice to on-hold.
What to do
Upgrade to a fixed version: 2.8.63.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- AyeCode Ltd Payment forms, Buy now buttons, and Invoicing System | GetPaid
fixed in 2.8.63
Evidence 2
- Patch
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-119748
Is CVE-2026-119748 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-119748?
Payment forms, Buy now buttons, and Invoicing System | GetPaid: before 2.8.63.Source: cve.now feed data
How do I fix CVE-2026-119748?
Upgrade to a fixed version: 2.8.63.Source: cve.now feed data