Skip to main content
← Vulnerabilities

GetPaid WordPress Plugin < 2.8.63 Incorrect Authorization via REST API

Affects GetPaid WordPress plugin versions before 2.8.63, where logged-in users with lower-privileged roles such as Editor or Author can reach invoices and items they should not. Fixed in 2.8.63.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 2.8.63
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. GetPaid plugin versions before 2.8.63 Attacker must be an authenticated user with a lower-privileged role such as Editor or Author

15Pcve.now Index 15 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity7.1/10CVSS 7.1
  • No patch0/5No signal

What would change the score

  • Would score about 65 if added to CISA KEV
  • Would score about 60 if CISA's SSVC rates exploitation active
  • Would score about 22 if CISA's SSVC rates it automatable

CVE-2026-119747 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects Payment forms, Buy now buttons, and Invoicing System | GetPaid; fixed in 2.8.63.

Published
Last modified
Published
Not listed in CISA KEV
15/100 · provisional
Specific setups only
Fix
Fixed in 2.8.63
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The GetPaid plugin for WordPress, before a certain patched release, lets logged-in users with lower-privileged roles such as Editor or Author bypass its invoicing permission check through the REST API. Remotely reachable with a low-privilege account, the flaw allows listing other users' invoices, marking pending invoices as paid without recording a payment, or creating published items and new invoices.

Read the original description

The GetPaid plugin for WordPress before 2.8.63 contains an incorrect authorization vulnerability where the check_post_permissions() method in includes/api/class-getpaid-rest-posts-controller.php maps REST operations to generic WordPress post capabilities instead of enforcing the plugin's manage_invoicing permission. Authenticated users with lower-privileged roles such as Editor or Author can exploit this flaw to list other users' invoices, mark pending invoices as paid without recording payment transactions, or create published items and new invoices through the REST API.

What to do

  • Check whether your setup matches what the bug needs.

    GetPaid plugin versions before 2.8.63 Attacker must be an authenticated user with a lower-privileged role such as Editor or Author
  • Upgrade to a fixed version: 2.8.63.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • AyeCode Ltd Payment forms, Buy now buttons, and Invoicing System | GetPaid

    fixed in 2.8.63

Evidence 2

  1. Patch
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-119747

Is CVE-2026-119747 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A flaw in the plugin's REST API authorization checks lets lower-privileged logged-in users list other users' invoices, mark pending invoices as paid without recording a payment transaction, and create published items and new invoices.Source: vulncheck.com

Which versions are affected by CVE-2026-119747?

Payment forms, Buy now buttons, and Invoicing System | GetPaid: before 2.8.63.Source: cve.now feed data

Am I affected, and how do I check?

GetPaid plugin versions before 2.8.63 are affected, but only for authenticated users with lower-privileged roles such as Editor or Author. To check a site, look at the installed version shown on the WordPress Plugins screen for GetPaid.Source: vulncheck.com

How do I fix CVE-2026-119747?

Update the GetPaid plugin to version 2.8.63 or later.Source: vulncheck.com