Skip to main content
← All vulnerabilities
CVE-2026-119577EUVD-2026-113931GHSA-V25H-F6WW-7597

ArcadeDB before 26.10.2 Improper Session Revocation in Wire-Protocol Connections

Affects ArcadeDB 26.10.1 and earlier when Postgres, Bolt, MongoDB or Redis wire-protocol connections stay open after a user is deleted, loses a grant, or changes password. Rated CVSS 7.6 (high). Fixed in 26.10.2.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 26.10.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

ArcadeDB, a multi-model database, is affected in its wire-protocol connections (Postgres, Bolt, MongoDB, and Redis interfaces). A user whose access has been revoked, deleted, or changed can keep reading and writing data through a connection that was already open before the change.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

ArcadeDB before 26.10.2 contains an improper authorization vulnerability that allows revoked users to retain access through already-open Postgres, Bolt, MongoDB, or Redis wire-protocol connections. Attackers holding an existing connection can keep reading and writing data after deletion, grant removal, or password rotation, because executors keep a stale ServerSecurityUser.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  4. Record last updated

Affected versions

  • ArcadeData arcadedb

    fixed in 26.10.2

References 2

GitHub · ArcadeData/arcadedb

vulncheck.com

FAQ

Questions about CVE-2026-119577

What does this mean?

A connection that was opened and authenticated before a user was deleted, lost its database grant, or had its password changed keeps the access it had at login. The person holding that connection can keep reading and writing data after the account change.Source: github.com, vulncheck.com

Am I affected, and how do I check?

ArcadeDB 26.10.1 and earlier, before 26.10.2, are affected. The issue concerns the Postgres, Bolt, MongoDB and Redis wire-protocol listeners, so check your installed version and whether those protocols are enabled.Source: github.com, vulncheck.com

What should I do about it?

Upgrade to ArcadeDB 26.10.2 or later, which fixes the issue. If you cannot upgrade right away, restart the server or the wire-protocol listeners after revoking a user so that connections opened before the change are closed.Source: github.com, vulncheck.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data