Skip to main content
← All vulnerabilities
CVE-2026-119575

ArcadeDB 26.8.1 before 26.10.2 SSRF via ALTER DATABASE LOAD CSV Block List

Affects ArcadeDB from 26.8.1 before 26.10.2 for users holding updateDatabaseSettings on a database, especially where that permission is granted without updateSecurity. Fixed in 26.10.2.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 26.10.2
None on Exploit-DB, Metasploit or GitHub

Summary

ArcadeDB, a multi-model database, is affected: authenticated users with database-settings permissions can remove the block list that restricts LOAD CSV requests to internal addresses. This lets them make the server fetch cloud metadata and internal or loopback services, exposing sensitive information that should be unreachable from outside.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

ArcadeDB from 26.8.1 before 26.10.2 contains a server-side request forgery vulnerability that allows authenticated users with updateDatabaseSettings to disable the LOAD CSV IP block list via ALTER DATABASE. Attackers can set arcadedb.opencypher.loadCsv.blockedIpRanges to an empty string, then issue LOAD CSV requests to read cloud metadata and internal loopback or private services.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • ArcadeData arcadedb

    From 26.8.1 · fixed in 26.10.2

References 2

GitHub · ArcadeData/arcadedb

vulncheck.com

FAQ

Questions about CVE-2026-119575

What does this mean?

A user with the updateDatabaseSettings permission can clear the LOAD CSV block list. The server can then request internal HTTP or HTTPS addresses, such as cloud instance metadata, and return the response body as query rows.Source: vulncheck.com, github.com

Am I affected, and how do I check?

Versions from 26.8.1 before 26.10.2 are in range. The setup that matters is users granted updateDatabaseSettings on a database, especially where that permission was granted without updateSecurity; check the installed version and the permissions granted to database users.Source: vulncheck.com, github.com

What should I do about it?

Upgrade to ArcadeDB 26.10.2 or later, which is the fixed version listed for this range. The checked facts give no separate vendor fix entry, so confirm the fix against the upstream advisory.Source: vulncheck.com, github.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data