WordPress Royal Event theme <= 2.0 - PHP Object Injection vulnerability
Affects the Royal Event WordPress theme by ThemeREX, versions up to and including 2.0. CVSS rates it critical at 9.8. No fixed version is listed in the checked facts.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: total
Summary
The Royal Event theme for WordPress, developed by ThemeREX, is affected by this vulnerability. An attacker could exploit the flaw to inject malicious PHP objects through untrusted data, which could potentially lead to code execution or compromise of the affected website.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Deserialization of Untrusted Data vulnerability in ThemeREX Royal Event allows Object Injection. This issue affects Royal Event: from n/a through 2.0.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: total
- Record last updated
- Posted on X by cve.now
Affected versions
- ThemeREX Royal Event
through 2.0
References 1
Questions about CVE-2026-119526
What does this mean?
This is a PHP Object Injection flaw, where the site handles data in a way that lets an attacker manipulate it to run harmful actions on the server.Source: patchstack.com
Am I affected, and how do I check?
The vulnerable range is Royal Event theme versions up to and including 2.0. The installed version can be seen in the WordPress admin under Appearance > Themes, or in the theme's style.css header.Source: patchstack.com
What should I do about it?
The checked facts do not name a fixed version, so no upgrade target can be given from them. Check the vendor's channels for an update to a version later than 2.0.Source: patchstack.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What if there's no patch?
The checked facts list no workaround. Until a fix is available, the facts give no steps for limiting the theme's exposure.Source: patchstack.com