Skip to main content
← Vulnerabilities

WordPress Radius Booking — Booking Calendar for Appointments & Services plugin <= 1.0.20 - PHP Object Injection vulnerability

Affects the Radius Booking plugin for WordPress, version 1.0.20 and earlier. Fixed in 1.0.21. CVSS scores it 9.8 (critical); no vendor severity is given.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

9.8CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 1.0.21
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 1.0.21.

Published
Last modified
0.39% · 32nd percentile
27/100 · provisional
Unclear
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

The Radius Booking — Booking Calendar for Appointments & Services WordPress plugin contains a PHP object injection flaw caused by unsafe deserialization of untrusted data. It can be reached remotely, without logging in, and could let an attacker run code or otherwise take serious control of the affected site.

Read the original description

Deserialization of Untrusted Data vulnerability in Mamunur Rashid Radius Booking — Booking Calendar for Appointments &amp; Services radius-booking allows Object Injection.This issue affects Radius Booking — Booking Calendar for Appointments &amp; Services: from n/a through 1.0.20.

cve.now Index

27Pcve.now Index 27 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.8/10CVSS 9.8
  • No patch0/5No signal

What would change the score

  • Would score about 72 if added to CISA KEV
  • Would score about 67 if CISA's SSVC rates exploitation active
  • Would score about 32 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 1.0.21.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now

Affected versions

  • radius-booking

    through 1.0.20

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-119516

Is CVE-2026-119516 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

This is a PHP Object Injection flaw. According to the checked facts, it lets attackers manipulate how the site processes data so that harmful actions run on the server.Source: patchstack.com, cve.org

Which versions are affected by CVE-2026-119516?

radius-booking: through 1.0.20.Source: cve.now feed data

Am I affected, and how do I check?

Versions 1.0.20 and earlier of the Radius Booking plugin for WordPress are affected. To check, look up the installed plugin version on the WordPress Plugins page or in the plugin's details.Source: patchstack.com, cve.org

How do I fix CVE-2026-119516?

Update the Radius Booking plugin to version 1.0.21 or later. No workaround is listed in the checked facts.Source: patchstack.com, cve.org