Skip to main content
← Vulnerabilities

WordPress WP Photo Album Plus plugin <= 9.3.05.003 - Cross Site Scripting (XSS) vulnerability

Affects WP Photo Album Plus plugin version 9.3.05.003 and earlier for WordPress. Fixed in 9.3.06.001.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 9.3.06.001
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. WP Photo Album Plus plugin version 9.3.05.003 and earlier (vulnerable versions).

19Pcve.now Index 19 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity7.1/10CVSS 7.1
  • No patch0/5No signal

What would change the score

  • Would score about 69 if added to CISA KEV
  • Would score about 64 if CISA's SSVC rates exploitation active

CVE-2026-119477 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects WP Photo Album Plus; fixed in 9.3.06.001.

Published
Last modified
Published
Not listed in CISA KEV
0.15% · 3rd percentile
19/100 · provisional
Specific setups only
Fix
Fixed in 9.3.06.001
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The WP Photo Album Plus plugin for WordPress contains a stored cross-site scripting flaw that lets an attacker inject malicious script into pages it generates. The attacker can reach it remotely without logging in, but a user has to interact with the page (for example by clicking a link or visiting the page) for the attack to run.

Read the original description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Jacob N. Breetvelt WP Photo Album Plus wp-photo-album-plus allows Stored XSS.This issue affects WP Photo Album Plus: from n/a through 9.3.05.003.

What to do

  • Check whether your setup matches what the bug needs.

    WP Photo Album Plus plugin version 9.3.05.003 and earlier (vulnerable versions).
  • Upgrade to a fixed version: 9.3.06.001.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • wp-photo-album-plus

    through 9.3.05.003

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-119477

Is CVE-2026-119477 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The plugin has a cross-site scripting flaw that lets an attacker inject malicious scripts into the site. Those scripts can steal visitor data or hijack visitor accounts.Source: patchstack.com, cve.org

Which versions are affected by CVE-2026-119477?

wp-photo-album-plus: through 9.3.05.003.Source: cve.now feed data

Am I affected, and how do I check?

The advisory covers WP Photo Album Plus version 9.3.05.003 and earlier. To check, look at the installed plugin version on the Plugins page of the WordPress admin.Source: patchstack.com, cve.org

How do I fix CVE-2026-119477?

Update the WP Photo Album Plus plugin to version 9.3.06.001 or later.Source: patchstack.com, cve.org