WordPress Noptin plugin <= 4.4.2 - Cross Site Scripting (XSS) vulnerability
Affects the Noptin newsletter plugin for WordPress, version 4.4.2 and earlier. Fixed in 4.4.3.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 4.4.3
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Noptin plugin version 4.4.2 or earlier
- Exploitation0/40No signal
- Exposure12/25Specific setups only, reachable over the network without a login
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity7.1/10CVSS 7.1
- No patch0/5No signal
What would change the score
- Would score about 69 if added to CISA KEV
- Would score about 64 if CISA's SSVC rates exploitation active
CVE-2026-119468 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects Noptin; fixed in 4.4.3.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 19/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 4.4.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
The Noptin newsletter plugin for WordPress has a stored cross-site scripting flaw that lets an attacker inject malicious scripts into its web pages. An attacker can reach it remotely over the network without logging in, but a user must take some action for the script to run.
Read the original description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Noptin Newsletter Team Noptin newsletter-optin-box allows Stored XSS.This issue affects Noptin: from n/a through 4.4.2.
What to do
Check whether your setup matches what the bug needs.
Noptin plugin version 4.4.2 or earlierUpgrade to a fixed version: 4.4.3.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- newsletter-optin-box
through 4.4.2
Evidence 1
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-119468
Is CVE-2026-119468 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Noptin fails to properly sanitize some input, which lets an attacker inject malicious scripts into pages of the site. Those scripts can steal visitor data or hijack user accounts.Source: patchstack.com
Which versions are affected by CVE-2026-119468?
newsletter-optin-box: through 4.4.2.Source: cve.now feed data
Am I affected, and how do I check?
All Noptin plugin versions up to and including 4.4.2 are listed as affected. To check, look at the installed version under Plugins in the WordPress admin dashboard.Source: patchstack.com
How do I fix CVE-2026-119468?
Update the Noptin plugin to version 4.4.3 or later, as the vendor advises.Source: patchstack.com