Skip to main content
← All vulnerabilities
CVE-2026-119408EUVD-2026-113792

n8n before 2.42.6, 2.43.3 and 3.0.1 Code Execution Outside Task Runner Isolation via Deprecated Function Nodes

Affects n8n before 2.42.6, 2.43.3 and 3.0.1 where a workflow uses the deprecated Function, Function Item or LangChain Code node. Fixed in 2.42.6, 2.43.3 and 3.0.1.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 2.43.3, 2.42.6, 3.0.1
None on Exploit-DB, Metasploit or GitHub

Summary

n8n, a workflow automation platform, is affected by this vulnerability in its deprecated Function, Function Item, and LangChain Code nodes. An authenticated user who can create, modify, or import workflows could run arbitrary JavaScript inside the n8n main process, bypassing task runner isolation and potentially gaining remote code execution on the server.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

n8n before 2.42.6, 2.43.x before 2.43.3, and 3.x before 3.0.1 contains a remote code execution vulnerability via deprecated Function, Function Item, and LangChain Code nodes running outside task runner isolation. Authenticated users who can create, modify, or import workflows naming these hidden node types can execute JavaScript in the n8n main process.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • n8n-io n8n

    From 2.43.0 · fixed in 2.43.3

  • n8n-io n8n

    fixed in 2.42.6

  • n8n-io n8n

    From 3.0.0 · fixed in 3.0.1

References 9

GitHub · n8n-io/n8n

abraxaslabs.tech

vulncheck.com

FAQ

Questions about CVE-2026-119408

What does this mean?

An authenticated user who can create or modify workflows can use the deprecated Function, Function Item, or LangChain Code nodes to run arbitrary JavaScript in the n8n main process. This bypasses the task runner isolation that applies to the Code node.Source: github.com

Am I affected, and how do I check?

The advisory lists n8n versions before 2.42.6, 2.43.3 and 3.0.1 as affected. To check a installation, look at the n8n version it runs and whether any workflow uses the Function, Function Item, or LangChain Code node.Source: github.com

What should I do about it?

Upgrade to n8n 2.42.6, 2.43.3, or 3.0.1 or later, which the advisory says remediates the vulnerability.Source: github.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data