Skip to main content
← All vulnerabilities
CVE-2026-119025EUVD-2026-112744GHSA-JGWM-4PMQ-R4W4GHSA-Q978-78C7-PHQW

open 7.2.0 before 11.0.0 OS Command Injection via PowerShell on Windows

Only affects open 7.2.0 before 11.0.0 on Windows or WSL outside a container, where open uses PowerShell. Fixed in 11.0.0.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 11.0.0, 2.12.0, 1.18.33
1 proof of concept on GitHub

Summary

The open npm package, a Node.js tool for launching files and URLs, is affected on Windows and WSL systems. An attacker who supplies a specially crafted URL, such as one returned by a malicious server, can run arbitrary PowerShell commands on the user's machine.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

open 7.2.0 before 11.0.0 contains an OS command injection vulnerability that allows attackers to execute PowerShell code by supplying crafted URLs on Windows and WSL. Attackers can embed $(...) subexpressions in URLs, such as OAuth authorization_endpoint values from malicious MCP servers, which execute when index.js passes them unescaped to powershell -EncodedCommand.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • sindresorhus open

    From 7.2.0 · fixed in 11.0.0

  • modelcontextprotocol inspector

    From 2.0.0 · fixed in 2.12.0

  • anomalyco opencode

    From 1.0.137 · fixed in 1.18.33

References 9

GitHub · sindresorhus/open

GitHub · modelcontextprotocol/inspector

GitHub · anomalyco/opencode

vulncheck.com

GitHub · shouvikkkk/oauth-sink-check

FAQ

Questions about CVE-2026-119025

What does this mean?

On Windows and WSL, open passes its target to PowerShell without escaping it properly, so a crafted URL can run commands. The advisory says a remote MCP server the user has connected to can run arbitrary code as that user.Source: github.com

Am I affected, and how do I check?

open versions from 7.2.0 before 11.0.0 on Windows or WSL outside a container are affected; macOS and Linux are not. Check the open version in the project's package.json or lockfile. The advisory also lists MCP Inspector 2.0.0 before 2.12.0 and OpenCode 1.0.137 before 1.18.33, where auto-open is on by default unless MCP_AUTO_OPEN_ENABLED=false or Vitest is running, and stderr is a TTY.Source: github.com

What should I do about it?

Upgrade open to 11.0.0 or later, which escapes the target through executePowerShell.escapeArgument. For MCP Inspector, the fixed version is 2.12.0, and for OpenCode it is 1.18.33.Source: github.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. Public exploit code exists (a proof of concept on GitHub).Source: cve.now feed data