Skip to main content
← All vulnerabilities
CVE-2026-118697EUVD-2026-114245GHSA-C9GR-394R-65GG

In JetBrains Toolbox App before 3.9.1 and 3.8.2; IntelliJ IDEA before 2026.3 and 2026.2.4, the jetbrainsd daemon trusted compromised…

Toolbox App before 3.9.1 and 3.8.2, and IntelliJ IDEA before 2026.2.4, install the jetbrainsd background service. The fix is in jetbrainsd 0.9.9728.

Published
Last modified
published
Not listed in CISA KEV
Unclear
Fix
Fixed in 3.9.1, 3.8.2, 2026.2.4
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

The JetBrains Toolbox App and IntelliJ IDEA software are affected. The jetbrainsd background service could be tricked into trusting compromised intermediate certificates, which could allow an attacker to undermine the trust checks used to verify software and connections.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

In JetBrains Toolbox App before 3.9.1 and 3.8.2; IntelliJ IDEA before 2026.3 and 2026.2.4, the jetbrainsd daemon trusted compromised intermediate certificates

Timeline

  1. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  2. CVE published
  3. First seen by cve.now
  4. Posted on X by cve.now1 day
  5. Record last updated

Affected versions

  • JetBrains Toolbox App

    From 3.9.0 · fixed in 3.9.1; fixed in 3.8.2

  • JetBrains IntelliJ IDEA

    fixed in 2026.2.4

References 4

jetbrains.com

blog.jetbrains.com

emudhra.com

bugzilla.mozilla.org

FAQ

Questions about CVE-2026-118697

What does this mean?

The jetbrainsd background service trusts its own built-in list of certificates, which includes compromised eMudhra intermediate certificates. An attacker who can intercept network traffic could use them to impersonate websites and services that JetBrains tools connect to.Source: blog.jetbrains.com

Am I affected, and how do I check?

Toolbox App versions before 3.9.1 (including 3.9.0) and before 3.8.2 are affected, as are IntelliJ IDEA versions before 2026.2.4. Compare the installed product version against these ranges.Source: blog.jetbrains.com

What should I do about it?

Update Toolbox App to 3.9.1 or 3.8.2 or later, and update IntelliJ IDEA to 2026.2.4 or later. The fix is in jetbrainsd 0.9.9728.Source: blog.jetbrains.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data