In JetBrains IntelliJ IDEA, PyCharm, PhpStorm, RubyMine and WebStorm before 2026.3, 2026.2.4, 2026.1.5.1, and 2025.3.6.2; GoLand before…
Affects JetBrains IDEs and tools that use the bundled JetBrains Runtime trust store, including IntelliJ IDEA, PyCharm and WebStorm. Fixed in 2026.2.4, 2026.1.5.1 and 2025.3.6.2 for those products.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2026.2.4, 2026.1.5.1, 2025.3.6.2, 2025.3.5.2, 2026.1.5.3, and 11 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
JetBrains development tools, including IntelliJ IDEA, PyCharm, PhpStorm, RubyMine, WebStorm, GoLand, Rider, CLion, DataGrip, RustRover, and DataSpell, are affected through their embedded browser component. Because it trusted revoked intermediate certificates, the browser could accept connections to websites whose certificates should have been rejected, potentially exposing users to impersonation or interception of data.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
In JetBrains IntelliJ IDEA, PyCharm, PhpStorm, RubyMine and WebStorm before 2026.3, 2026.2.4, 2026.1.5.1, and 2025.3.6.2; GoLand before 2026.3, 2026.2.4, 2026.1.5.1, and 2025.3.5.2; Rider before 2026.3, 2026.2.4, 2026.1.5.3, and 2025.3.5.3; CLion before 2026.3, 2026.2.4.1, 2026.1.5.2, and 2025.3.6.3; DataGrip before 2026.3, 2026.2.6.1, 2026.1.4.1, and 2025.3.6.1; RustRover before 2026.3, 2026.2.5, 2026.1.4.1, and 2025.3.7.1; DataSpell before 2026.1.3.1 and 2025.3.3.1, the embedded browser trusted revoked intermediate certificates
Timeline
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- CVE published
- First seen by cve.now1 day
- Record last updated
Affected versions
- JetBrains IntelliJ IDEA
From 2026.2 · fixed in 2026.2.4; From 2026.1 · fixed in 2026.1.5.1; fixed in 2025.3.6.2
- JetBrains PyCharm
From 2026.2 · fixed in 2026.2.4; From 2026.1 · fixed in 2026.1.5.1; fixed in 2025.3.6.2
- JetBrains PhpStorm
From 2026.2 · fixed in 2026.2.4; From 2026.1 · fixed in 2026.1.5.1; fixed in 2025.3.6.2
- JetBrains RubyMine
From 2026.2 · fixed in 2026.2.4; From 2026.1 · fixed in 2026.1.5.1; fixed in 2025.3.6.2
- JetBrains WebStorm
From 2026.2 · fixed in 2026.2.4; From 2026.1 · fixed in 2026.1.5.1; fixed in 2025.3.6.2
- JetBrains GoLand
From 2026.2 · fixed in 2026.2.4; From 2026.1 · fixed in 2026.1.5.1; fixed in 2025.3.5.2
- JetBrains Rider
From 2026.2 · fixed in 2026.2.4; From 2026.1 · fixed in 2026.1.5.3; fixed in 2025.3.5.3
- JetBrains CLion
From 2026.2 · fixed in 2026.2.4.1; From 2026.1 · fixed in 2026.1.5.2; fixed in 2025.3.6.3
- JetBrains DataGrip
From 2026.2 · fixed in 2026.2.6.1; From 2026.1 · fixed in 2026.1.4.1; fixed in 2025.3.6.1
- JetBrains RustRover
From 2026.2 · fixed in 2026.2.5; From 2026.1 · fixed in 2026.1.4.1; fixed in 2025.3.7.1
- JetBrains DataSpell
From 2026.1 · fixed in 2026.1.3.1; fixed in 2025.3.3.1
References 4
jetbrains.com
blog.jetbrains.com
emudhra.com
bugzilla.mozilla.org
Questions about CVE-2026-118696
What does this mean?
The bundled JetBrains Runtime trusts certificates from compromised eMudhra intermediate certificates. An attacker who can intercept network traffic could use them to impersonate websites and services that JetBrains tools connect to, enabling interception of those connections.Source: blog.jetbrains.com
Am I affected, and how do I check?
Affected products include IntelliJ IDEA, PyCharm, PhpStorm, RubyMine, WebStorm, GoLand, Rider, CLion, DataGrip, RustRover and DataSpell, with versions before the fixed releases listed for each product. For IDEs, the embedded browser (JCEF) is also affected. To check, compare the version shown under the IDE's About dialog with the fixed versions for that product.Source: blog.jetbrains.com
What should I do about it?
Upgrade to the fixed release for the product, such as 2026.2.4, 2026.1.5.1 or 2025.3.6.2 for IntelliJ IDEA. Where an upgrade is not yet possible, disable the embedded browser (JCEF) by switching off the ide.browser.jcef.enabled registry key and restarting.Source: blog.jetbrains.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Is the fix complete?
The advisory lists fixed versions but describes the fix as partial. The embedded browser stays unprotected if the network blocks Google's update servers.Source: blog.jetbrains.com