Surfer < 1.8.1.759 - Contributor+ Privilege Escalation via Editor API Key Disclosure
- Exploited
- No known exploitation
- Fix
- Fixed in 1.8.1.759
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 1.8.1.759.
- Last modified
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.13% · 2nd percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 11/100 · provisional
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
The Surfer WordPress plugin exposes a sensitive API credential to low-privileged users through the post editor page. Because that credential is the only check protecting its privileged REST API, users with contributor-level access or higher can use it to publish arbitrary posts and perform other privileged actions.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
The Surfer WordPress plugin before 1.8.1.759 discloses a sensitive API credential to low-privileged users through the post editor page and relies on that same credential as the sole authorization for its privileged REST API, allowing users with contributor-level access and above to read the credential and escalate to publishing arbitrary posts and other privileged actions.
cve.now Index
- Exploitation0/40No signal
- Exposure3/25Reachable over the network · Unknown: No advisory context yet
- Reach?/20Unknown. No tracked technology or package matched
- Severity7.5/10CVSS 6.5, total technical impact per CISA
- No patch0/5No signal
What would change the score
- Would score about 66 if added to CISA KEV
- Would score about 61 if CISA's SSVC rates exploitation active
- Would score about 30 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 1.8.1.759.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Unknown Surfer
fixed in 1.8.1.759
Evidence 1
- Exploit
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-118639
Is CVE-2026-118639 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-118639?
Surfer: before 1.8.1.759.Source: cve.now feed data
How do I fix CVE-2026-118639?
Upgrade to a fixed version: 1.8.1.759.Source: cve.now feed data