Skip to main content
← Vulnerabilities

MLflow get-artifacts Server-Side Request Forgery Information Disclosure Vulnerability

MLflow installations earlier than 3.17.0 are affected by this server-side request forgery flaw in get-artifacts. The fix is in MLflow 3.17.0.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.2HighCNA
Exploited
No known exploitation
Fix
Fixed in 3.17.0
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 3.17.0.

25Pcve.now Index 25 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure17/25No login or user action needed, reachable over the network without a login · Data gap: Advisories don't say whether default setups are affected
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity8.2/10CVSS 8.2
  • No patch0/5No signal

What would change the score

  • Would score about 70 if added to CISA KEV
  • Would score about 65 if CISA's SSVC rates exploitation active
  • Would score about 30 if advisories confirm default setups are exposed

CVE-2026-118628 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.2 (high) and affects MLflow; fixed in 3.17.0.

Published
Last modified
Published
Not listed in CISA KEV
25/100 · provisional
Unclear
Fix
Fixed in 3.17.0
None on Exploit-DB, Metasploit or GitHub

Summary

This vulnerability affects MLflow, an open-source machine learning platform, allowing unauthenticated remote attackers to trick its server into requesting internal resources on their behalf and thereby expose sensitive information. The flaw stems from the get-artifacts function failing to properly validate a supplied URI before accessing it.

Read the original description

MLflow get-artifacts Server-Side Request Forgery Information Disclosure Vulnerability. This vulnerability allows remote attackers to disclose sensitive information on affected installations of MLflow. Authentication is not required to exploit this vulnerability. The specific flaw exists within the get-artifacts function. The issue results from the lack of proper validation of a URI prior to accessing resources. An attacker can leverage this vulnerability to disclose information in the context of the server. Was ZDI-CAN-28192.

What to do

  • Upgrade to a fixed version: 3.17.0.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • MLflow MLflow

    3.8.0

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-118628

Is CVE-2026-118628 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The get-artifacts function does not properly validate URIs, which enables a server-side request forgery. Through it, sensitive information from the server's context can be disclosed.Source: zerodayinitiative.com

Which versions are affected by CVE-2026-118628?

MLflow: version 3.8.0.Source: cve.now feed data

Am I affected, and how do I check?

MLflow versions earlier than 3.17.0 are affected. To check an installation, look at its MLflow version, for example with the command mlflow --version or pip show mlflow.Source: zerodayinitiative.com

How do I fix CVE-2026-118628?

Upgrade MLflow to version 3.17.0 or later, which contains the fix. The sources provided do not list a workaround.Source: zerodayinitiative.com